WUs erroring on T7200 w/ 7.0.28 & ap_6.02r561_10.5+_OSX64


log in

Advanced search

Message boards : Number crunching : WUs erroring on T7200 w/ 7.0.28 & ap_6.02r561_10.5+_OSX64

Author Message
Gecko
Volunteer tester
Send message
Joined: 17 Nov 99
Posts: 440
Credit: 6,062,469
RAC: 652
United States
Message 1262940 - Posted: 21 Jul 2012, 14:35:39 UTC

@ Urs, Joe, Arkayn

Having problem with ap_6.02r561_10.5+_OSX64 running on iMac T7200
WUs are immediately giving error.
FYI, ONLY running AP using the supplied app_info.xml.
I have reset as well as deleted project & folders w/ fresh BOINC and app installs.

Still same problem. :>/

Anyone run into this before?

Fri Jul 20 17:19:16 2012 | | OS: Mac OS X 10.5.8 (Darwin 9.8.0)
Fri Jul 20 17:19:16 2012 | | Starting BOINC client version 7.0.28 for x86_64-apple-darwin
Fri Jul 20 17:19:16 2012 | SETI@home | Found app_info.xml; using anonymous platform


Sat Jul 21 08:12:43 2012 | SETI@home | Started download of ap_12mr10ad_B2_P1_00100_20120721_30951.wu
Sat Jul 21 08:16:33 2012 | SETI@home | Finished download of ap_12mr10ad_B2_P1_00100_20120721_30951.wu
Sat Jul 21 08:16:33 2012 | SETI@home | Starting task ap_12mr10ad_B2_P1_00100_20120721_30951.wu_0 using astropulse_v6 version 602 in slot 0
Sat Jul 21 08:16:34 2012 | SETI@home | Computation for task ap_12mr10ad_B2_P1_00100_20120721_30951.wu_0 finished
Sat Jul 21 08:16:34 2012 | SETI@home | Output file ap_12mr10ad_B2_P1_00100_20120721_30951.wu_0_0 for task ap_12mr10ad_B2_P1_00100_20120721_30951.wu_0 absent


Suggestions, ideas, solutions greatly appreciated. :>)
Thx Gents!, Gecko

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3695
Credit: 48,765,402
RAC: 6,137
United States
Message 1262955 - Posted: 21 Jul 2012, 15:13:29 UTC - in response to Message 1262940.

Did you use the install script to install the files or do it manually?

Check that the app is listed as an executable.
____________

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8671
Credit: 51,873,771
RAC: 49,400
United Kingdom
Message 1262956 - Posted: 21 Jul 2012, 15:15:13 UTC - in response to Message 1262940.

The message log line 'output file absent' isn't really enough: it tells you that an error happened, but the devs are going to want to know what error, and why.

For that, they need access to the stderr_txt of a reported (errored) task - but your computers are hidden, so the vital information is inaccessible.

Please supply a TaskID or (preferably) HostID to enable diagnostics.

Wembley
Volunteer tester
Avatar
Send message
Joined: 16 Sep 09
Posts: 415
Credit: 888,257
RAC: 0
United States
Message 1262985 - Posted: 21 Jul 2012, 16:45:34 UTC

When an application quits that quickly I would look at a permissions problem (is it executable etc.) or a missing library or something that prevents it from getting loaded.
____________


Donate with your searches and online buys:
http://www.goodsearch.com/toolbar/university-of-california-setihome

Gecko
Volunteer tester
Send message
Joined: 17 Nov 99
Posts: 440
Credit: 6,062,469
RAC: 652
United States
Message 1263056 - Posted: 21 Jul 2012, 19:36:46 UTC - in response to Message 1262956.

The message log line 'output file absent' isn't really enough: it tells you that an error happened, but the devs are going to want to know what error, and why.

For that, they need access to the stderr_txt of a reported (errored) task - but your computers are hidden, so the vital information is inaccessible.

Please supply a TaskID or (preferably) HostID to enable diagnostics.


Thanks for the replies.
Computer is visible now.
I used the script to install, but get the same w/ manual install as well.
The application does show as intel unix executable, so that's not the issue.

Host ID = 2722345

http://setiathome.berkeley.edu/result.php?resultid=2534190327

Stderr output

<core_client_version>7.0.28</core_client_version>
<![CDATA[
<message>
process got signal 5
</message>
<stderr_txt>
dyld: lazy symbol binding failed: Symbol not found: __ZNSi10_M_extractIdEERSiRT_
Referenced from: /Library/Application Support/BOINC Data/slots/0/../../projects/setiathome.berkeley.edu/ap_6.02r561_OSX64
Expected in: /usr/lib/libstdc++.6.dylib

dyld: Symbol not found: __ZNSi10_M_extractIdEERSiRT_
Referenced from: /Library/Application Support/BOINC Data/slots/0/../../projects/setiathome.berkeley.edu/ap_6.02r561_OSX64
Expected in: /usr/lib/libstdc++.6.dylib


</stderr_txt>
]]>

Wembley
Volunteer tester
Avatar
Send message
Joined: 16 Sep 09
Posts: 415
Credit: 888,257
RAC: 0
United States
Message 1263061 - Posted: 21 Jul 2012, 19:46:01 UTC - in response to Message 1263056.
Last modified: 21 Jul 2012, 19:47:50 UTC

dyld: lazy symbol binding failed: Symbol not found: __ZNSi10_M_extractIdEERSiRT_
Referenced from: /Library/Application Support/BOINC Data/slots/0/../../projects/setiathome.berkeley.edu/ap_6.02r561_OSX64
Expected in: /usr/lib/libstdc++.6.dylib

dyld: Symbol not found: __ZNSi10_M_extractIdEERSiRT_
Referenced from: /Library/Application Support/BOINC Data/slots/0/../../projects/setiathome.berkeley.edu/ap_6.02r561_OSX64
Expected in: /usr/lib/libstdc++.6.dylib

The executable is referencing a symbol in the stdc++ library that isn't there.

Are your libraries up to date?

[edit]And your computers are still hidden.
____________


Donate with your searches and online buys:
http://www.goodsearch.com/toolbar/university-of-california-setihome

Gecko
Volunteer tester
Send message
Joined: 17 Nov 99
Posts: 440
Credit: 6,062,469
RAC: 652
United States
Message 1263065 - Posted: 21 Jul 2012, 20:11:54 UTC - in response to Message 1263061.
Last modified: 21 Jul 2012, 20:12:27 UTC


The executable is referencing a symbol in the stdc++ library that isn't there.

Are your libraries up to date?
And your computers are still hidden.

Thanks for the reply Wembley.
Computer isn't hidden. When I log out, I can see it.

Re: up to date libraries. Not sure.
Haven't had to update them in the past on OSX.
So, what library would need to be updated for this to work, and how to find?
IIRC, Arkayn has same rig as me, so if it's a library issue, should have affected his old warhorse as well???

Wembley
Volunteer tester
Avatar
Send message
Joined: 16 Sep 09
Posts: 415
Credit: 888,257
RAC: 0
United States
Message 1263072 - Posted: 21 Jul 2012, 20:19:31 UTC - in response to Message 1263065.
Last modified: 21 Jul 2012, 20:21:49 UTC

"Computers hidden"

is what I see when I try to look.

I don't run OS X so I can't tell you how to update your libraries, I'll leave that for someone else.
____________


Donate with your searches and online buys:
http://www.goodsearch.com/toolbar/university-of-california-setihome

Juha
Volunteer tester
Send message
Joined: 7 Mar 04
Posts: 184
Credit: 143,295
RAC: 21
Finland
Message 1263083 - Posted: 21 Jul 2012, 21:04:09 UTC

Gecko's user page tells me too that his computers are hidden but following the result link to his computer gives owner as Gecko instead of Anonymous. The user page is probably just cached.

As for the error. Gecko's computer is running Darwin 9.8.0 and Arkayn's is running Darwin 10.8.0. Perhaps who ever compiled the app made it accidentally require a newer version of OS X.

Wembley
Volunteer tester
Avatar
Send message
Joined: 16 Sep 09
Posts: 415
Credit: 888,257
RAC: 0
United States
Message 1263085 - Posted: 21 Jul 2012, 21:10:19 UTC - in response to Message 1263083.
Last modified: 21 Jul 2012, 21:12:53 UTC

As for the error. Gecko's computer is running Darwin 9.8.0 and Arkayn's is running Darwin 10.8.0. Perhaps who ever compiled the app made it accidentally require a newer version of OS X.

That could be it. If I'm reading the file name correctly: "ap_6.02r561_10.5+_OSX64" it looks like it requires 10.5 or greater.

But then again his logs report this:
Fri Jul 20 17:19:16 2012 | | OS: Mac OS X 10.5.8 (Darwin 9.8.0)

So is it 10.5+ for OSX or for Darwin? (mac version numbers are screwy imho)
____________


Donate with your searches and online buys:
http://www.goodsearch.com/toolbar/university-of-california-setihome

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3695
Credit: 48,765,402
RAC: 6,137
United States
Message 1263098 - Posted: 21 Jul 2012, 21:32:15 UTC - in response to Message 1263085.

As for the error. Gecko's computer is running Darwin 9.8.0 and Arkayn's is running Darwin 10.8.0. Perhaps who ever compiled the app made it accidentally require a newer version of OS X.

That could be it. If I'm reading the file name correctly: "ap_6.02r561_10.5+_OSX64" it looks like it requires 10.5 or greater.

But then again his logs report this:
Fri Jul 20 17:19:16 2012 | | OS: Mac OS X 10.5.8 (Darwin 9.8.0)

So is it 10.5+ for OSX or for Darwin? (mac version numbers are screwy imho)


His computer should have the correct OSX version as 10.5+ means OSX version.
____________

Gecko
Volunteer tester
Send message
Joined: 17 Nov 99
Posts: 440
Credit: 6,062,469
RAC: 652
United States
Message 1263101 - Posted: 21 Jul 2012, 21:34:03 UTC - in response to Message 1263085.

As for the error. Gecko's computer is running Darwin 9.8.0 and Arkayn's is running Darwin 10.8.0. Perhaps who ever compiled the app made it accidentally require a newer version of OS X.

That could be it. If I'm reading the file name correctly: "ap_6.02r561_10.5+_OSX64" it looks like it requires 10.5 or greater.

But then again his logs report this:
Fri Jul 20 17:19:16 2012 | | OS: Mac OS X 10.5.8 (Darwin 9.8.0)

So is it 10.5+ for OSX or for Darwin? (mac version numbers are screwy imho)

OSX 10.5.x is Leopard OS.
OSX 10.6.x is Snow Leopard

I am running the final update of Leopard, 10.5.8 so if 10.5+ is the minimum, it should work.
A mystery.....

Message boards : Number crunching : WUs erroring on T7200 w/ 7.0.28 & ap_6.02r561_10.5+_OSX64

Copyright © 2014 University of California