New AstroPulse for GPU ( ATi & NV) released (r1316)

Message boards : Number crunching : New AstroPulse for GPU ( ATi & NV) released (r1316)

To post messages, you must log in.

Previous · 1 . . . 7 · 8 · 9 · 10 · 11 · Next

AuthorMessage
Profile BilBg
Volunteer tester
Avatar

Send message
Joined: 27 May 07
Posts: 3654
Credit: 8,596,598
RAC: 1,132
Bulgaria
Message 1266822 - Posted: 2 Aug 2012, 20:41:40 UTC - in response to Message 1266502.  

AstroPulse WU's are running fine again. :)

OK, you are happy now.
Will you help others be happy too? :)

Your problem will affect all other SETI users which run stock/standard AstroPulse app
which also run the same antivirus (TrendMicro ?).

So if you are paid customer of TrendMicro - make report to them asking to check the issue with that file, e.g.:

"
I think I found a false-positive given by TrendMicro
Will you check this file to confirm it is virus free or not:
http://boinc2.ssl.berkeley.edu/sah/download_fanout/ap_graphics_6.01_windows_intelx86.exe

Reports are clean:
https://www.virustotal.com/file/6be058f0ac2997fba8d37445d268b3efccd54a64f9b2b35fe4478e6300a39d41/analysis/1341799812/

http://r.virscan.org/report/364572dc4292f30b165afe592eb2a626.html

http://virusscan.jotti.org/en/scanresult/f8165a9bc2bcc55cde281bc4089a2af4d6cc348f

"

P.S.
1) Since I'm not a customer of TrendMicro they will not pay attention if I make this report.

2) I'm not sure (as you didn't say clearly) was the file blocked when you get it manually by the browser?





- ALF - "Find out what you don't do well ..... then don't do it!" :)
ID: 1266822 · Report as offensive
Profile Mike
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 29586
Credit: 49,125,912
RAC: 17,355
Germany
Message 1266836 - Posted: 2 Aug 2012, 21:14:35 UTC

Please stay on topic.
This issue has nothing to do with the app in question here.

With each crime and every kindness we birth our future.
ID: 1266836 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 5431
Credit: 66,411,900
RAC: 12,818
Russia
Message 1266930 - Posted: 3 Aug 2012, 6:32:30 UTC - in response to Message 1266716.  
Last modified: 3 Aug 2012, 6:32:53 UTC

Only as Info, Application runs without errors on a low low lowest end HD4350 ^^ ~24h for 1 WU


Thanks for report!
Then we should find out, what differs with Wedge009's case where tasks are failing badly.

Working config:
Name: ATI RV710
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1546
Version: OpenCL 1.0 AMD-APP-SDK-v2.5 (732.1)

Config with failures:
Name: ATI RV730
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1664
Version: OpenCL 1.0 AMD-APP (851.4)

Besides of slightly different hardware (but both can be classified as low-end ATi HD4xxx cards with workgroup size of 128 instead of usual 256) there is apparent difference in used drivers.
ID: 1266930 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1266942 - Posted: 3 Aug 2012, 7:26:57 UTC

I had a look at dskag's host: there's only one WU been processed and it's a high-percentage blanked one, too, so most of the work was done by the CPU (that's why it was so slow).

Looks like it's running Catalyst 11.9 - my HD 4670 host is using Catalyst 12.1. 11.9 falls in between that series of Catalyst 11.3 and 11.11 where CPU usage was abnormally high, I thought. But if you still think it's a good idea, Raistmer, for me to try Catalyst 11.9, I will try to do it in between AP tasks. Will have to hunt down the AGP version, too...
Soli Deo Gloria
ID: 1266942 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 5431
Credit: 66,411,900
RAC: 12,818
Russia
Message 1266984 - Posted: 3 Aug 2012, 9:40:47 UTC - in response to Message 1266942.  

So you run over AGP, perhaps it's another difference. High blanking means that initial data preparation was done on CPU (where blanking applies). After that stage all work done on GPU too.

It's really hard to judge on only 1 task indeed, especially because your host sometimes produces good results too. Lets gather more statistics. And yes, if you could switch to older CAt driver at least for some time I think it's worth to try.

Most changes in last release were made in FFA part (repetitive pulses search), but overflow in single pulses no way connected to it - that's strange...
ID: 1266984 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1266987 - Posted: 3 Aug 2012, 9:56:51 UTC
Last modified: 3 Aug 2012, 9:57:38 UTC

Yeah, AGP is yet another variable to eliminate.

I'm looking for the Catalyst 11.9 WinXP AGP drivers. I know AMD keeps them on their server even though they might not show direct links on their public pages any more. But I can't remember the AGP drivers file name - looks like their current AGP release is a 'legacy' Catalyst 12.6. No good for OpenCL on WinXP, anyway.
Soli Deo Gloria
ID: 1266987 · Report as offensive
ClaggyProject Donor
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4623
Credit: 46,352,825
RAC: 2,947
United Kingdom
Message 1266993 - Posted: 3 Aug 2012, 10:40:16 UTC - in response to Message 1266987.  

Yeah, AGP is yet another variable to eliminate.

I'm looking for the Catalyst 11.9 WinXP AGP drivers. I know AMD keeps them on their server even though they might not show direct links on their public pages any more. But I can't remember the AGP drivers file name - looks like their current AGP release is a 'legacy' Catalyst 12.6. No good for OpenCL on WinXP, anyway.
Here's the url, you'll have to go to an AMD page, probably the AGP Hotfix web page to get it to work:

http://www2.ati.com/drivers/hotfix/11-9_agp-hotfix_xp32_dd_ccc.exe

http://support.amd.com/us/kbarticles/Pages/CatalystAGPHotfix.aspx

Claggy
ID: 1266993 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1266995 - Posted: 3 Aug 2012, 10:57:28 UTC
Last modified: 3 Aug 2012, 10:58:12 UTC

Thanks, Claggy. I was missing the hotfix sub-directory.

AMD has allowed direct downloads for a while now, so don't have to worry about referrers any more.
Soli Deo Gloria
ID: 1266995 · Report as offensive
Profile dskagcommunity
Volunteer tester
Avatar

Send message
Joined: 24 Feb 11
Posts: 43
Credit: 2,206,384
RAC: 0
Austria
Message 1267034 - Posted: 3 Aug 2012, 13:31:58 UTC
Last modified: 3 Aug 2012, 13:49:07 UTC

Do i understand that right? You use an AGP 4xxx Card? I think that i read anywhere that the AGP versions of the 4xxx cards dont run on OpenCL or something (but yes it will report as OpenCL device). But thats a long time ago, dont know where i read that. (wanted to buy an aditional AGP 4xxxx card before put some AGP machines in trash at this point and looked on the web how it run).

Or does anyone here run a AGP 4xxx Card with validated Results to correct that?

I will run some more AP on the 4350 (when i get a new task ^^) because Raistmer wrote 1 tasks is not that representaive. But your right, the usage of cpu was damn high i saw now O.o This card only has 96Gflops what is vverrrryyy low so i dont know how much the GPU or the CPU trotteling eatch other because the CPU is a "greenIT" CPU with the power of i think only a P4 3,6Ghz (but i will look next task with GPUz and Taskmanager how much it needs the components). I just have bad experience with 12.x drivers and cos its my fileserver i dont try to update the catalyst, im aware of a hard to remove Bluescreen on startup again ^^ And dont have any computer left to try it there :/
ID: 1267034 · Report as offensive
Profile Mike
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 29586
Credit: 49,125,912
RAC: 17,355
Germany
Message 1267042 - Posted: 3 Aug 2012, 13:52:28 UTC

Since 11.9 drivers still have the 100% CPU bug i dont think much was calculated by the GPU itself.

With each crime and every kindness we birth our future.
ID: 1267042 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1267045 - Posted: 3 Aug 2012, 13:58:13 UTC
Last modified: 3 Aug 2012, 14:02:27 UTC

Yes, it's a HD 4670 with AGP interface. There is no difference to HD 4670 PCIe other than it has a PCIe-to-AGP chip (I think ATI started doing this since the X1950), so it definitely supports OpenCL. The HD 4000 series cards only have 'beta-level' OpenCL support, according to AMD's APP SDK notes - seems to me that's why HD 5000 series and later are much more stable for OpenCL processing.

I have been using this card for a long time, just with increased incidence of invalid results when using the AP r1316 build. I've reverted to r555 and have just completed a task with credit, so it definitely works... just not reliably, apparently.

Another reason why your ATI AP task used so much CPU - aside from high-percentage blanking, you're using the Catalyst 11.9 driver which still suffers from the 100% CPU usage bug with OpenCL applications. I've just confirmed this by installing Catalyst 11.9 (after a DriverSweep) and running the AP bench-test (r1316, unroll 10, ffa_block 4096, ffa_block_fetch 2096):

Catalyst 12.1: 476.587 total, 25.547 CPU
Catalyst 11.9: 478.172 total, 432.984 CPU

Raistmer, even if Catalyst 11.9 somehow proves to be stable, there's no way I can run with such a buggy, CPU-heavy driver. I'm re-installing Catalyst 12.1 after posting this.

Edit: Looks like Mike snuck in his post while I was writing this.
Soli Deo Gloria
ID: 1267045 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 5431
Credit: 66,411,900
RAC: 12,818
Russia
Message 1267051 - Posted: 3 Aug 2012, 14:07:46 UTC - in response to Message 1267045.  


Catalyst 12.1: 476.587 total, 25.547 CPU
Catalyst 11.9: 478.172 total, 432.984 CPU

Raistmer, even if Catalyst 11.9 somehow proves to be stable, there's no way I can run with such a buggy, CPU-heavy driver. I'm re-installing Catalyst 12.1 after posting this.


What about result validness for these 2 runs?

ID: 1267051 · Report as offensive
Profile dskagcommunity
Volunteer tester
Avatar

Send message
Joined: 24 Feb 11
Posts: 43
Credit: 2,206,384
RAC: 0
Austria
Message 1267055 - Posted: 3 Aug 2012, 14:11:43 UTC

Hm ok good to know.
ID: 1267055 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1267059 - Posted: 3 Aug 2012, 14:13:55 UTC

This was just using your ap_Zblank_2LC67_silent_ffa.wu test work-unit, so no server validation, but both produced the same results file.
Soli Deo Gloria
ID: 1267059 · Report as offensive
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 16 Jun 01
Posts: 5431
Credit: 66,411,900
RAC: 12,818
Russia
Message 1267070 - Posted: 3 Aug 2012, 14:32:31 UTC - in response to Message 1267059.  

This was just using your ap_Zblank_2LC67_silent_ffa.wu test work-unit, so no server validation, but both produced the same results file.

w/o overflow?
ID: 1267070 · Report as offensive
Wedge009
Volunteer tester
Avatar

Send message
Joined: 3 Apr 99
Posts: 448
Credit: 241,942,593
RAC: 91,032
Australia
Message 1267072 - Posted: 3 Aug 2012, 14:42:51 UTC
Last modified: 3 Aug 2012, 14:43:28 UTC

That's right, no overflow. Both registered 1 single pulse.
Soli Deo Gloria
ID: 1267072 · Report as offensive
Kamu

Send message
Joined: 19 Jan 02
Posts: 56
Credit: 10,807,600
RAC: 0
Finland
Message 1267881 - Posted: 5 Aug 2012, 12:14:50 UTC

Hi

Which graphics card/driver is best (fastest) at the moment with these r1316/r1363 for AP crunching?

If I'm buying new hardware which card(s) should I buy?

-Kimmo-

Computers: obelix
ID: 1267881 · Report as offensive
Profile Mike
Volunteer tester
Avatar

Send message
Joined: 17 Feb 01
Posts: 29586
Credit: 49,125,912
RAC: 17,355
Germany
Message 1267887 - Posted: 5 Aug 2012, 12:41:46 UTC

HD 7970 should be fastest on APs atm.
Less than one hour for three instances on low blanked tasks.

With each crime and every kindness we birth our future.
ID: 1267887 · Report as offensive
Profile Paul D Harris
Volunteer tester

Send message
Joined: 1 Dec 99
Posts: 1122
Credit: 33,600,005
RAC: 0
United States
Message 1271186 - Posted: 13 Aug 2012, 17:24:02 UTC

I finally got an AP for my 460 NV card I have everything set to default it should run OK?

<app>
    <name>astropulse_v6</name>
</app>
<file_info>
    <name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</name>
    <executable/>
</file_info>
<file_info>
    <name>libfftw3f-3.dll</name>
    <executable/>
</file_info>
<app_version>
    <app_name>astropulse_v6</app_name>
    <version_num>601</version_num>
    <avg_ncpus>0.04</avg_ncpus>
    <max_ncpus>0.04</max_ncpus>
    <platform>windows_intelx86</platform>
    <plan_class>cuda_fermi</plan_class>
    <cmdline></cmdline>
    <coproc>
        <type>CUDA</type>
        <count>0.5</count>
    </coproc>
    <file_ref>
        <file_name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</file_name>
        <main_program/>
    </file_ref>
    <file_info>
        <name>llibfftw3f-3.dll</name>
        <executable/>
    </file_info>
</app_version>
<app_version>
    <app_name>astropulse_v6</app_name>
    <version_num>601</version_num>
    <avg_ncpus>0.04</avg_ncpus>
    <max_ncpus>0.04</max_ncpus>
    <platform>windows_x86_64</platform>
    <plan_class>cuda_fermi</plan_class>
    <cmdline>-</cmdline>
    <coproc>
        <type>CUDA</type>
        <count>0.5</count>
    </coproc>
    <file_ref>
        <file_name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</file_name>
        <main_program/>
    </file_ref>
    <file_info>
        <name>llibfftw3f-3.dll</name>
        <executable/>
    </file_info>
</app_version>

ID: 1271186 · Report as offensive
ClaggyProject Donor
Volunteer tester

Send message
Joined: 5 Jul 99
Posts: 4623
Credit: 46,352,825
RAC: 2,947
United Kingdom
Message 1271188 - Posted: 13 Aug 2012, 17:31:50 UTC - in response to Message 1271186.  

Only one typo that i can see, just remove the -ve sign from the last <cmdline>-</cmdline> entry,

Claggy
ID: 1271188 · Report as offensive
Previous · 1 . . . 7 · 8 · 9 · 10 · 11 · Next

Message boards : Number crunching : New AstroPulse for GPU ( ATi & NV) released (r1316)


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.