New AstroPulse for GPU ( ATi & NV) released (r1316)


log in

Advanced search

Message boards : Number crunching : New AstroPulse for GPU ( ATi & NV) released (r1316)

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 11 · Next
Author Message
Profile Raistmer
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 16 Jun 01
Posts: 3588
Credit: 48,748,384
RAC: 23,453
Russia
Message 1261731 - Posted: 18 Jul 2012, 8:39:50 UTC

How big influence of busy CPU can be: http://devgurus.amd.com/message/1282763#1282763

LadyL
Volunteer tester
Avatar
Send message
Joined: 14 Sep 11
Posts: 1679
Credit: 5,230,097
RAC: 0
Message 1261752 - Posted: 18 Jul 2012, 9:57:42 UTC - in response to Message 1261675.

Will this be added to the lunatics app soon?


There will not be a new Lunatics installer until they release v7 for Multibeam here first.

Currently they are working on AP on beta.


I/we do installers when they become necessary (e.g. because there are bugs or the versions change as with AP6 and MB7) or when the development warrants a new release.

At this time MB7 development is stalled on Beta - personally I don't think we'll see MB7 on main before next spring and there will be a new installer if and when it happens.

That leaves the second reason for new installers.
With MB7 that far off, it's very likely that there will be an interim installer when the different developments have matured enough.
Soon is relative, but I wouldn't say soon.
____________
I'm not the Pope. I don't speak Ex Cathedra!

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4212
Credit: 34,471,349
RAC: 17,682
United Kingdom
Message 1261756 - Posted: 18 Jul 2012, 10:22:45 UTC - in response to Message 1261725.
Last modified: 18 Jul 2012, 10:23:13 UTC

You receive units in astro nvidia GPU? For me despites fair to have that checked GPU and astro v6 in my preferences ... still nothing

Edit: made ​​with google translation (French-English)


Did you fix your app_info?

you have made no mention of doing so.

Claggy

Profile [AF>EDLS] Polynesia
Volunteer tester
Avatar
Send message
Joined: 1 Apr 09
Posts: 54
Credit: 4,137,056
RAC: 188
France
Message 1261911 - Posted: 18 Jul 2012, 17:42:51 UTC - in response to Message 1261756.

Yes I fixed the part about Astropulse GPU, I think ...

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<platform>windows_intelx86</platform>
<plan_class>cuda</plan_class>
<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<platform>windows_x86_64</platform>
<plan_class>cuda</plan_class>
<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>
____________


Alliance Francophone

Horacio
Send message
Joined: 14 Jan 00
Posts: 536
Credit: 75,838,092
RAC: 21,442
Argentina
Message 1261924 - Posted: 18 Jul 2012, 18:21:51 UTC - in response to Message 1261911.

Yes I fixed the part about Astropulse GPU, I think ...

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<platform>windows_intelx86</platform>
<plan_class>cuda</plan_class>
<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>
<file_ref>
<file_name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>601</version_num>
<avg_ncpus>0.04</avg_ncpus>
<max_ncpus>0.2</max_ncpus>
<platform>windows_x86_64</platform>
<plan_class>cuda</plan_class>
<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>


I think, the version numbers used should be 604 for the GPU part of the app_info, leave 601 only in the CPU part.
Not sure if this is the reason for you not getting APs, but IIRC, BOINC will crunch all the WUs, with the first app stated in the ap_info that match the version...

____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4212
Credit: 34,471,349
RAC: 17,682
United Kingdom
Message 1261950 - Posted: 18 Jul 2012, 19:28:04 UTC - in response to Message 1261911.

Yes I fixed the part about Astropulse GPU, I think ...

You got an AP Wu for your GTX470 about 20 minutes ago, just need to get it downloaded and put it to the front of your cue now,

Claggy

Profile [AF>EDLS] Polynesia
Volunteer tester
Avatar
Send message
Joined: 1 Apr 09
Posts: 54
Credit: 4,137,056
RAC: 188
France
Message 1261990 - Posted: 18 Jul 2012, 21:23:06 UTC

ok i change by 604 instead of 601
____________


Alliance Francophone

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24895
Credit: 34,405,255
RAC: 10,784
Germany
Message 1261994 - Posted: 18 Jul 2012, 21:24:59 UTC

Your first unit got validated.

Very good times as well.

____________

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4212
Credit: 34,471,349
RAC: 17,682
United Kingdom
Message 1261998 - Posted: 18 Jul 2012, 21:33:56 UTC - in response to Message 1261990.
Last modified: 18 Jul 2012, 21:38:36 UTC

ok i change by 604 instead of 601

You shouldn't abort all your MB Wu's just to start one single AP v6 Wu, just suspend the MB Wu's instead,

Can't say i'm impressed with your runtime, it's a lot slower than my factory overclocked GTX460 (with the same parameters), freeing a core up will improve the runtimes no end, but with increased CPU usage,

Claggy

Profile [AF>EDLS] Polynesia
Volunteer tester
Avatar
Send message
Joined: 1 Apr 09
Posts: 54
Credit: 4,137,056
RAC: 188
France
Message 1262001 - Posted: 18 Jul 2012, 21:35:22 UTC

all this is the main project of Seti and not Séti beta?
____________


Alliance Francophone

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24895
Credit: 34,405,255
RAC: 10,784
Germany
Message 1262013 - Posted: 18 Jul 2012, 22:01:02 UTC - in response to Message 1261998.

ok i change by 604 instead of 601

You shouldn't abort all your MB Wu's just to start one single AP v6 Wu, just suspend the MB Wu's instead,

Can't say i'm impressed with your runtime, it's a lot slower than my factory overclocked GTX460 (with the same parameters), freeing a core up will improve the runtimes no end, but with increased CPU usage,

Claggy


300 MHZ less Claggy no wonders.
And your host uses full CPU core on a 2600K.
No clue why you are running with CPU lock.

____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2879
Credit: 6,453,552
RAC: 2,785
Bulgaria
Message 1262051 - Posted: 19 Jul 2012, 0:34:17 UTC - in response to Message 1261911.


You continue to use contradicting options:

<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>

For this new app don't use -instances_per_device:
<cmdline>-unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>

... or even only:
<cmdline>-unroll 7</cmdline>


(? is it optimal for NVIDIA to use -unroll = 1/2 of the "Number of compute units: 14"?
http://setiathome.berkeley.edu/result.php?resultid=2530286745
)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24895
Credit: 34,405,255
RAC: 10,784
Germany
Message 1262058 - Posted: 19 Jul 2012, 0:42:42 UTC - in response to Message 1262051.


You continue to use contradicting options:

<cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>
<coproc>
<type>CUDA</type>
<count>0.5</count>
</coproc>

For this new app don't use -instances_per_device:
<cmdline>-unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline>

... or even only:
<cmdline>-unroll 7</cmdline>


(? is it optimal for NVIDIA to use -unroll = 1/2 of the "Number of compute units: 14"?
http://setiathome.berkeley.edu/result.php?resultid=2530286745
)




You can still use -instances_per_device but its not needed anymore.
Evenso -sbs switch has no effect on actual ap apps.
Unroll has to be tested carefully on nvidia cards.
Some cards can´t cope with high unroll factor.

____________

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2879
Credit: 6,453,552
RAC: 2,785
Bulgaria
Message 1262062 - Posted: 19 Jul 2012, 0:52:43 UTC - in response to Message 1262058.


What happens if the two options contradict?:
-instances_per_device 1
<count>0.5</count>

Will it run only one AP task on the GPU but leave 0.5 GPU 'free' (as seen by BOINC) to run MB task (if MB also have <count>0.5</count>)?


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 24895
Credit: 34,405,255
RAC: 10,784
Germany
Message 1262068 - Posted: 19 Jul 2012, 1:04:17 UTC - in response to Message 1262062.


What happens if the two options contradict?:
-instances_per_device 1
<count>0.5</count>

Will it run only one AP task on the GPU but leave 0.5 GPU 'free' (as seen by BOINC) to run MB task (if MB also have <count>0.5</count>)?



Since GPU_lock is disabled it will run 2 instances with count 0.5.
If available of course.

It makes no sense using -instances-per_device 1 and count 0.5.
Better remove it.

____________

Speedy
Volunteer tester
Avatar
Send message
Joined: 26 Jun 04
Posts: 702
Credit: 5,992,565
RAC: 2,026
New Zealand
Message 1262129 - Posted: 19 Jul 2012, 6:46:40 UTC
Last modified: 19 Jul 2012, 6:50:30 UTC

I've installed NV r1316. I'm using client 6.10.60 under the transfer tab it's trying to dl AP6_win_x86_SSE2_OpenCL_NV_r1316 this file is in the Seti folder. Here's the AP part of my app info file. I haven't put anything in the ap_cmdline file at this point. I got the files from AP6_win_x86_SSE2_OpenCL_NV_r1316 zip

<app_info> <file_info> <name>AP6_win_x86_SSE2_OpenCL_NV_r1316</name> <executable/> </file_info> <app> <name>astropulse_v6</name> </app> <app_version> <app_name>astropulse_v6</app_name> <version_num>601</version_num> <avg_ncpus>0.04</avg_ncpus> <max_ncpus>0.2</max_ncpus> <platform>windows_intelx86</platform> <plan_class>cuda_fermi</plan_class> <cmdline>-instances_per_device 1 -unroll 10 -ffa_block 6144 -ffa_block_fetch 1536 -sbs 256</cmdline> <coproc> <type>CUDA</type> <count>1</count> </coproc> <file_ref> <file_name>AP6_win_x86_SSE2_OpenCL_NV_r1316</file_name> <main_program/> </file_ref> </app_version>

____________

Live in NZ y not join Smile City?

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8760
Credit: 52,711,348
RAC: 23,533
United Kingdom
Message 1262135 - Posted: 19 Jul 2012, 7:28:38 UTC - in response to Message 1262129.

You have

<name>AP6_win_x86_SSE2_OpenCL_NV_r1316</name>

Everyone else has

<name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</name>

ClaggyProject donor
Volunteer tester
Send message
Joined: 5 Jul 99
Posts: 4212
Credit: 34,471,349
RAC: 17,682
United Kingdom
Message 1262148 - Posted: 19 Jul 2012, 8:36:35 UTC - in response to Message 1262129.

Having the following first might be a problem too:

<file_info> <name>AP6_win_x86_SSE2_OpenCL_NV_r1316.exe</name> <executable/> </file_info>


The normal convention is the <app> section is first for a given app:

<app> <name>astropulse_v6</name> </app>


Claggy

Speedy
Volunteer tester
Avatar
Send message
Joined: 26 Jun 04
Posts: 702
Credit: 5,992,565
RAC: 2,026
New Zealand
Message 1262153 - Posted: 19 Jul 2012, 8:47:15 UTC - in response to Message 1262135.

Thanks Richard. File is no longer in transfer tab :) How ever in my message log I'm getting
SETI@home[error] State file error: missing application file AP6_win_x86_SSE2_OpenCL_NV_r1316 Have I missed something or is this line ok?

____________

Live in NZ y not join Smile City?

Speedy
Volunteer tester
Avatar
Send message
Joined: 26 Jun 04
Posts: 702
Credit: 5,992,565
RAC: 2,026
New Zealand
Message 1262156 - Posted: 19 Jul 2012, 9:01:18 UTC - in response to Message 1262148.

Thanks Claggy I've corrected this but I'm still getting 19/07/2012 8:54:02 p.m. SETI@home [error] State file error: missing application file AP6_win_x86_SSE2_OpenCL_NV_r1316 in message log

____________

Live in NZ y not join Smile City?

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 11 · Next

Message boards : Number crunching : New AstroPulse for GPU ( ATi & NV) released (r1316)

Copyright © 2014 University of California