"Your app_info.xml file doesn't have a usable version of AstroPulse v6"


log in

Advanced search

Message boards : Number crunching : "Your app_info.xml file doesn't have a usable version of AstroPulse v6"

Author Message
Profile Mr. KevvyProject donor
Volunteer tester
Avatar
Send message
Joined: 15 May 99
Posts: 731
Credit: 78,417,822
RAC: 46,751
Canada
Message 1218450 - Posted: 14 Apr 2012, 22:47:55 UTC
Last modified: 14 Apr 2012, 22:49:33 UTC

I realize that this is because I'm using the Lunatics platform and the AP 6.01 app. doesn't have an installer that adds the relevant entries into app_info.xml; it's just an EXE and DLL that get dropped into \Application Data\BOINC\projects\setiathome.berkeley.edu.

What I have in app_info.xml for 5.05 is:

</app> <file_info> <name>ap_5.05r409_SSE.exe</name> <executable/> </file_info> <app_version> <app_name>astropulse_v505</app_name> <version_num>505</version_num> <file_ref> <file_name>ap_5.05r409_SSE.exe</file_name> <main_program/> </file_ref> </app_version>


If I just copy this block in app_info.xml and adjust for 6.01 accordingly will this work? I'd rather ask first just to avoid breaking anything. :^) (Also surprised that this isn't in the app.'s ZIP or a forum post there or here...) Thanks.
____________
“Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has.”
--- Margaret Mead

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8759
Credit: 52,708,783
RAC: 26,516
United Kingdom
Message 1218478 - Posted: 14 Apr 2012, 23:48:00 UTC - in response to Message 1218450.

NO: that ancient r409 application is not capable of producing correct results for Astropulse v6 tasks.

You will need the r555 or r557 applications to process the new work: both are backwards-compatible with any v505 work you may still have cached.

Better yet, the Lunatics v0.40 unified installer contains both of those AP v6-compatible apps, and will build you an app_info.xml file to support those apps (in both v6 and v505 mode), plus any other apps you need.

If you have any other special needs not covered by the installer, please explain what they are.

I realize that this is because I'm using the Lunatics platform and the AP 6.01 app. doesn't have an installer that adds the relevant entries into app_info.xml; it's just an EXE and DLL that get dropped into \Application Data\BOINC\projects\setiathome.berkeley.edu.

What I have in app_info.xml for 5.05 is:

</app> <file_info> <name>ap_5.05r409_SSE.exe</name> <executable/> </file_info> <app_version> <app_name>astropulse_v505</app_name> <version_num>505</version_num> <file_ref> <file_name>ap_5.05r409_SSE.exe</file_name> <main_program/> </file_ref> </app_version>


If I just copy this block in app_info.xml and adjust for 6.01 accordingly will this work? I'd rather ask first just to avoid breaking anything. :^) (Also surprised that this isn't in the app.'s ZIP or a forum post there or here...) Thanks.

Profile Mr. KevvyProject donor
Volunteer tester
Avatar
Send message
Joined: 15 May 99
Posts: 731
Credit: 78,417,822
RAC: 46,751
Canada
Message 1218508 - Posted: 15 Apr 2012, 0:27:24 UTC
Last modified: 15 Apr 2012, 0:29:36 UTC

Thanks for the reply... I installed the latest unified installer and it updated app_info.xml and BOINC no longer complains about the missing 6.01 app.

The problem, or why I didn't install 0.40 already: It appears that the Lunatics download page needs an update:

1 - Windows Seti@Home apps - The current Berkeley stock application version is 6.03 for multibeam and 5.05 for astropulse.
(emphasis mine)

Similary, the Windows app. page linked from the above indicates 5.05. However, when it's installed, it indicates 6.01 instead (and, its version of libfftw3f-3.dll is more recent than the version in the stand-alone AP 6.01... so what purpose does the standalone serve?)

Hope this helps.
____________
“Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has.”
--- Margaret Mead

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8759
Credit: 52,708,783
RAC: 26,516
United Kingdom
Message 1218512 - Posted: 15 Apr 2012, 0:35:13 UTC - in response to Message 1218508.

Thanks for the reply... I installed the latest unified installer and it updated app_info.xml and BOINC no longer complains about the missing 6.01 app.

The problem, or why I didn't install 0.40 already: It appears that the Lunatics download page needs an update:

1 - Windows Seti@Home apps - The current Berkeley stock application version is 6.03 for multibeam and 5.05 for astropulse.
(emphasis mine)

Similary, the Windows app. page linked from the above indicates 5.05. However, when it's installed, it indicates 6.01 instead (and, its version of libfftw3f-3.dll is more recent than the version in the stand-alone AP 6.01... so what purpose does the standalone serve?)

Hope this helps.

Thanks for the feedback. Unfortunately, I don't have the necessary permissions to maintain that part of the website, but I'll pass on your observations.

Josef W. SegurProject donor
Volunteer developer
Volunteer tester
Send message
Joined: 30 Oct 99
Posts: 4332
Credit: 1,113,463
RAC: 995
United States
Message 1218580 - Posted: 15 Apr 2012, 3:41:55 UTC - in response to Message 1218508.

Thanks for the reply... I installed the latest unified installer and it updated app_info.xml and BOINC no longer complains about the missing 6.01 app.

The problem, or why I didn't install 0.40 already: It appears that the Lunatics download page needs an update:

1 - Windows Seti@Home apps - The current Berkeley stock application version is 6.03 for multibeam and 5.05 for astropulse.
(emphasis mine)

Similary, the Windows app. page linked from the above indicates 5.05. However, when it's installed, it indicates 6.01 instead (and, its version of libfftw3f-3.dll is more recent than the version in the stand-alone AP 6.01... so what purpose does the standalone serve?)

Hope this helps.

Indeed it did, and should you or anyone else notice other misleading descriptions, etc., please do pass them on. I've edited the incorrect version info you noted and removed the 5.05 AP standalone packages. The 6.01 AP standalones would be useful to someone who had a considerably modified app_info.xml or who prefers to only do AP work, so I left them in place but accompanied by a note that they're also in the installer.

The libfftw3f-3.dll in the installer is actually the same file as in the standalone r555 package, but the file date was accidentally changed. The subversion repository system doesn't preserve dates by default on checked out files, that's the most likely culprit.
Joe

Profile Mr. KevvyProject donor
Volunteer tester
Avatar
Send message
Joined: 15 May 99
Posts: 731
Credit: 78,417,822
RAC: 46,751
Canada
Message 1218710 - Posted: 15 Apr 2012, 14:10:25 UTC

Excellent... glad that I posted this then and thanks for the reply.
And, of course, thanks for all the work on the Lunatics platform from the team. It's an amazing piece of work.
____________
“Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has.”
--- Margaret Mead

Profile ignorance is no excuse
Avatar
Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,321
RAC: 0
Korea, North
Message 1218716 - Posted: 15 Apr 2012, 14:28:53 UTC - in response to Message 1218710.

don't forget that you are responsible for updates and upgrades to your 3rd party apps. In the near future seti will be moving to the v7 multibeam app. Be sure to check in routinely because the Lunatics guys will be introducing their v7 apps at that time as well
____________
In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

Profile Mr. KevvyProject donor
Volunteer tester
Avatar
Send message
Joined: 15 May 99
Posts: 731
Credit: 78,417,822
RAC: 46,751
Canada
Message 1218747 - Posted: 15 Apr 2012, 15:58:24 UTC
Last modified: 15 Apr 2012, 15:58:49 UTC

I've tried several times over the course of years to register at Lunatics to get on a mailing list so I know when there are updates (is there one?) but:

Sorry, registration is currently disabled.

____________
“Never doubt that a small group of thoughtful, committed citizens can change the world; indeed, it's the only thing that ever has.”
--- Margaret Mead

Profile arkaynProject donor
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3721
Credit: 48,768,260
RAC: 1,737
United States
Message 1218756 - Posted: 15 Apr 2012, 16:35:27 UTC - in response to Message 1218747.

I've tried several times over the course of years to register at Lunatics to get on a mailing list so I know when there are updates (is there one?) but:

Sorry, registration is currently disabled.


No mailing list, but there is an RSS feed.
http://lunatics.kwsn.net/index.php?action=.xml;type=rss;sa=news;limit=15;board=15
____________

Profile ignorance is no excuse
Avatar
Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,321
RAC: 0
Korea, North
Message 1218775 - Posted: 15 Apr 2012, 17:15:07 UTC - in response to Message 1218756.

It wouldn't hurt to just look here. We are the second site to know when the apps are ready. They always announce the updates, whats changed, and how to install the updates right here.
____________
In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

Message boards : Number crunching : "Your app_info.xml file doesn't have a usable version of AstroPulse v6"

Copyright © 2014 University of California