Correct Lunatic's Settings for AMD HD5450


log in

Advanced search

Message boards : Number crunching : Correct Lunatic's Settings for AMD HD5450

1 · 2 · 3 · 4 · Next
Author Message
Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204502 - Posted: 10 Mar 2012, 10:26:20 UTC

Hi guys sorry to bother you again but does anyone know the correct settings for the AMD HD5450 chipset in Lunatic's 0.39 installation as when I first installed it I found it was running ok until, I restarted the PC and it has never worked since even after re-installation!


____________

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 25197
Credit: 34,806,459
RAC: 21,262
Germany
Message 1204507 - Posted: 10 Mar 2012, 10:36:03 UTC

You have to make sure OpenCL is activated by the drivers.
Use GPUz to see OpenCL is checked.

____________

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204512 - Posted: 10 Mar 2012, 10:57:46 UTC - in response to Message 1204507.

Thanks Mike, but as I am still a GPU noob can you tell me where to find GPUz please.
____________

Profile Bhagwanmike
Send message
Joined: 4 Jun 99
Posts: 21
Credit: 4,523,543
RAC: 8,451
United States
Message 1204513 - Posted: 10 Mar 2012, 11:07:01 UTC

You can get it from:
http://www.techpowerup.com/downloads/SysInfo/GPU-Z/

____________

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204515 - Posted: 10 Mar 2012, 11:12:10 UTC - in response to Message 1204513.
Last modified: 10 Mar 2012, 11:16:38 UTC

One again thanks guys! I found the OpenGL settings and enabled triple buffering as it was not selected. Will that help in any way?

Edit, OpenCL is not active according got GPUz! How do I activate it?
____________

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 25197
Credit: 34,806,459
RAC: 21,262
Germany
Message 1204518 - Posted: 10 Mar 2012, 11:22:06 UTC - in response to Message 1204515.

One again thanks guys! I found the OpenGL settings and enabled triple buffering as it was not selected. Will that help in any way?

Edit, OpenCL is not active according got GPUz! How do I activate it?


What i was thinking.
You need to install AMD drivers with OpenCL support.
The package says OpenCL runtime.

What drivers you are using ?
Its also shown in GPUz.

____________

Profile HAL9000
Volunteer tester
Avatar
Send message
Joined: 11 Sep 99
Posts: 4664
Credit: 123,686,403
RAC: 96,748
United States
Message 1204519 - Posted: 10 Mar 2012, 11:24:02 UTC

I don't see any machines in your hardware list with a HD5450.
When you start BOINC do you see a message like this one in the BOINC event log? Advanced > Event log or CTRL + SHIFT + E
3/10/2012 6:20:51 AM | | ATI GPU 0: ATI Radeon HD 5x00 series (Cedar) (CAL version 1.4.815, 1024MB, 120 GFLOPS peak)

If you see "no usable gpus detected" then there is something else afoot.
____________
SETI@home classic workunits: 93,865 CPU time: 863,447 hours

Join the BP6/VP6 User Group today!

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204521 - Posted: 10 Mar 2012, 11:41:48 UTC - in response to Message 1204519.

The HD5450 is not running on mine but my daughters! The Drivers I am running are the automatic updates selected for the card! I get no messages at all so I guess it's just the incorrect install settings plus OpenCL is not active.

The driver version is atiumdag 8.930.0.0 / win7
____________

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204522 - Posted: 10 Mar 2012, 11:44:10 UTC - in response to Message 1204519.

Looking through the event log it does say no usable GPU's found!
____________

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204523 - Posted: 10 Mar 2012, 11:45:30 UTC

Should I download this package? http://developer.amd.com/sdks/AMDAPPSDK/Pages/default.aspx

____________

Richard HaselgroveProject donor
Volunteer tester
Send message
Joined: 4 Jul 99
Posts: 8824
Credit: 53,572,825
RAC: 46,969
United Kingdom
Message 1204524 - Posted: 10 Mar 2012, 11:47:49 UTC - in response to Message 1204523.

Should I download this package? http://developer.amd.com/sdks/AMDAPPSDK/Pages/default.aspx

No, you don't need the full developer SDKs (Software Development Kits).

Just look for OpenCL or APP inclusive packages on the regular driver download page.

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 25197
Credit: 34,806,459
RAC: 21,262
Germany
Message 1204525 - Posted: 10 Mar 2012, 11:49:51 UTC
Last modified: 10 Mar 2012, 11:51:23 UTC

For win 7 32 bit.

http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista32.aspx

win 7 64 bit

http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx

Dont forget to uninstall old drivers first and reboot.
____________

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204527 - Posted: 10 Mar 2012, 11:52:36 UTC - in response to Message 1204525.

Thanks for the links, now the driver is sorted what about the install settings? As her PC is a core2 Duo running the HD5450 which settings should I use!
____________

Profile HAL9000
Volunteer tester
Avatar
Send message
Joined: 11 Sep 99
Posts: 4664
Credit: 123,686,403
RAC: 96,748
United States
Message 1204535 - Posted: 10 Mar 2012, 12:29:09 UTC - in response to Message 1204527.

Thanks for the links, now the driver is sorted what about the install settings? As her PC is a core2 Duo running the HD5450 which settings should I use!

The install settings for the driver? You can use the default values, which installs everything, if you like. I normally only uncheck one thing on their install. Which has to do with some media something or other that I don't need.

In GPU computing updating drivers can be a bad thing. So you might want to disable that for the machine.
____________
SETI@home classic workunits: 93,865 CPU time: 863,447 hours

Join the BP6/VP6 User Group today!

Profile Peter Cook
Volunteer tester
Avatar
Send message
Joined: 3 Jul 99
Posts: 107
Credit: 6,743,375
RAC: 6,931
United Kingdom
Message 1204536 - Posted: 10 Mar 2012, 12:40:36 UTC - in response to Message 1204535.

Great got OpenCl active now! So the last question for the HD5450 which Astropulse and Multibeam setting should I use for the Lunatics install?
____________

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 25197
Credit: 34,806,459
RAC: 21,262
Germany
Message 1204537 - Posted: 10 Mar 2012, 12:46:49 UTC - in response to Message 1204536.
Last modified: 10 Mar 2012, 12:47:53 UTC

Great got OpenCl active now! So the last question for the HD5450 which Astropulse and Multibeam setting should I use for the Lunatics install?


If you want to edit appinfo use this.

MB

-period_iterations_num 20 -instances_per_device 2 -no_gpu_lock

count 0.5

AP

-instances_per_device 2 -unroll 6 -ffa_block 4096 -ffa_block_fetch 2048

count 0.5

should work nicely.
____________

Profile ignorance is no excuse
Avatar
Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,321
RAC: 0
Korea, North
Message 1204540 - Posted: 10 Mar 2012, 12:56:31 UTC

You'd better start over. Clean out the old drivers by uninstalling and using driver sweep, then reinstall the fresh ones. ATI has a habit of not removing all its old drivers which will cause all sorts of running problems for crunching
____________
In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

Profile HAL9000
Volunteer tester
Avatar
Send message
Joined: 11 Sep 99
Posts: 4664
Credit: 123,686,403
RAC: 96,748
United States
Message 1204541 - Posted: 10 Mar 2012, 12:56:34 UTC - in response to Message 1204536.
Last modified: 10 Mar 2012, 12:59:12 UTC

Great got OpenCl active now! So the last question for the HD5450 which Astropulse and Multibeam setting should I use for the Lunatics install?

If the card has a Max work group size of 256 or greater then you probably want to use these options in the installer.



If this card is one of the ones with a Max work group size <256 then you would uncheck MultiBeam and choose the other AP option.

To find out what it supports you would open a command prompt and type clinfo. Then scroll up to find a section that looks something like this:
Platform Name: AMD Accelerated Parallel Processing Number of devices: 2 Device Type: CL_DEVICE_TYPE_GPU Device ID: 4098 Board name: AMD Radeon HD 6800 Series Max compute units: 14 Max work items dimensions: 3 Max work items[0]: 256 Max work items[1]: 256 Max work items[2]: 256 Max work group size: 256

____________
SETI@home classic workunits: 93,865 CPU time: 863,447 hours

Join the BP6/VP6 User Group today!

Profile MikeProject donor
Volunteer tester
Avatar
Send message
Joined: 17 Feb 01
Posts: 25197
Credit: 34,806,459
RAC: 21,262
Germany
Message 1204543 - Posted: 10 Mar 2012, 12:59:33 UTC - in response to Message 1204540.

You'd better start over. Clean out the old drivers by uninstalling and using driver sweep, then reinstall the fresh ones. ATI has a habit of not removing all its old drivers which will cause all sorts of running problems for crunching


Not neccessary because OpenCL wasn´t installed with old drivers.

____________

Profile ignorance is no excuse
Avatar
Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,321
RAC: 0
Korea, North
Message 1204545 - Posted: 10 Mar 2012, 13:01:36 UTC - in response to Message 1204543.
Last modified: 10 Mar 2012, 13:02:34 UTC

it's not necessarily the OpenCl that is going to crash the work either.

For ATI driver installs I tend to be a bit over zealous and anal about their installation. It saves time later trying to figure out what failed
____________
In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

1 · 2 · 3 · 4 · Next

Message boards : Number crunching : Correct Lunatic's Settings for AMD HD5450

Copyright © 2014 University of California