Unsupported processor - Globalscale Dreamplug


log in

Advanced search

Questions and Answers : Getting started : Unsupported processor - Globalscale Dreamplug

Author Message
AdrianO
Avatar
Send message
Joined: 23 Oct 00
Posts: 1
Credit: 401,081
RAC: 0
United Kingdom
Message 1121437 - Posted: 25 Jun 2011, 13:17:57 UTC

I have a Globalscale Dreamplug running Debian (Lenny). Installed the boinc client and successfully connected to my seti@home project account.

However, I cannot download any workload tasks. The error returned is:

22/06/2011 22:24:13 SETI@home Message from server: This project doesn't support computers of type arm-unknown-linux-gnueabi

Anyone have any ideas how to get this doing useful work?

Regards.

Profile ignorance is no excuse
Avatar
Send message
Joined: 4 Oct 00
Posts: 9529
Credit: 44,433,274
RAC: 0
Korea, North
Message 1121521 - Posted: 25 Jun 2011, 18:35:00 UTC - in response to Message 1121437.

there are several standard apps for S@H but yours isnt one of them. You'll most likely need the help of Dotsch to get your CPU to run S@H or any other project. Dotsch has several links for his special "CPU/linux" apps. I think he's your best bet to getting anything to run on that CPU
____________
In a rich man's house there is no place to spit but his face.
Diogenes Of Sinope

End terrorism by building a school

Profile Grand Admiral Thrawn
Avatar
Send message
Joined: 19 Feb 01
Posts: 53
Credit: 22,263,601
RAC: 0
Austria
Message 1147591 - Posted: 31 Aug 2011, 18:44:06 UTC

Do you by any chance have a working compiler on that box? Try "gcc --version". If not, try to install one like this: "aptitude install build-essential". This should give you the basic stuff for compiling your own code. You might also need other Libraries and Headers, like libfftw3/libfftw3-dev, boinc-dev etc., installable using aptitude.

If you can get to a reasonable build environment, you might be able to compile your own SETI@Home, latest sourcecode available [here]. I just did that myself recently on a MIPS platform on Debian, should be quite similar for ARM.

In case you really want to try that (it might be quite some work to get it done), I might be able to help..

It would be easier though, if somebody could just provide a statically linked precompiled binary for your platform..
____________
3dfx Voodoo5 6000 AGP HiNT Rev.A 3700 prototype, dead HiNT bridge

Profile BilBg
Volunteer tester
Avatar
Send message
Joined: 27 May 07
Posts: 2644
Credit: 6,001,874
RAC: 4,171
Bulgaria
Message 1147635 - Posted: 31 Aug 2011, 20:17:06 UTC - in response to Message 1121437.
Last modified: 31 Aug 2011, 20:29:23 UTC



http://packages.debian.org/search?arch=arm&keywords=boinc-app-seti

Package: boinc-app-seti
Version: 5.13+cvs20060510-4
Architecture: arm

Any link (mirror) you click here:
http://packages.debian.org/lenny/arm/boinc-app-seti/download

will give you the file:
boinc-app-seti_5.13 cvs20060510-4_arm.deb
(259 KB)


____________



- ALF - "Find out what you don't do well ..... then don't do it!" :)

Questions and Answers : Getting started : Unsupported processor - Globalscale Dreamplug

Copyright © 2014 University of California