Boinc will only run on the GPU and not my 4core CPU


log in

Advanced search

Questions and Answers : Getting started : Boinc will only run on the GPU and not my 4core CPU

Author Message
Richard Plumley
Volunteer tester
Avatar
Send message
Joined: 21 Jan 02
Posts: 9
Credit: 3,273,909
RAC: 0
United States
Message 977023 - Posted: 10 Mar 2010, 3:06:44 UTC

At first it ran on all 4 cores and the GPU. Ran for a week,then only ran on the GPU and 2 cores. Now it will only run on the GPU. I have checked and rechecked my preferences 3 times and they are correct. any ideas?
____________

OzzFan
Volunteer tester
Avatar
Send message
Joined: 9 Apr 02
Posts: 13706
Credit: 31,731,280
RAC: 12,754
United States
Message 977028 - Posted: 10 Mar 2010, 3:17:52 UTC - in response to Message 977023.

Every single workunit seems to be scheduled to use the GPU app and not the CPU app. Something must be preventing SETI from downloading more workunits for the CPU.
____________

Richard Plumley
Volunteer tester
Avatar
Send message
Joined: 21 Jan 02
Posts: 9
Credit: 3,273,909
RAC: 0
United States
Message 977066 - Posted: 10 Mar 2010, 6:46:09 UTC

Exactly, all units are for the GPU. None for the CPU. I have about 100 of these units. Anything I can do to correct this?
____________

Profile Gundolf Jahn
Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 361,386
RAC: 39
Germany
Message 977072 - Posted: 10 Mar 2010, 8:26:23 UTC - in response to Message 977066.

A temporary workaround would be to disable receiving CUDA tasks in the SETI@home preferences.

Are there any hints in the project properties (backoffs...)?

Gruß,
Gundolf
____________
Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

Richard Plumley
Volunteer tester
Avatar
Send message
Joined: 21 Jan 02
Posts: 9
Credit: 3,273,909
RAC: 0
United States
Message 978252 - Posted: 13 Mar 2010, 17:24:46 UTC

No hints or anything. Looks like the server does not have any work. Been like this for 3 days now.
____________

John McLeod VII
Volunteer developer
Volunteer tester
Avatar
Send message
Joined: 15 Jul 99
Posts: 24806
Credit: 530,622
RAC: 342
United States
Message 978489 - Posted: 14 Mar 2010, 5:41:40 UTC - in response to Message 978252.

No hints or anything. Looks like the server does not have any work. Been like this for 3 days now.

Yes, the server is short on work.
____________


BOINC WIKI

Profile Jeff East
Send message
Joined: 20 Apr 99
Posts: 1
Credit: 356,918
RAC: 83
Canada
Message 989789 - Posted: 17 Apr 2010, 8:08:45 UTC

Newbie question: how can you tell what CPU/GPU is being used on a particular work unit? I've got a Linux system, and with 'top' I can see that Astropulse last used CPU0 and Seti-Enhanced used CPU1, but I don't see that info inside the BOINC Manager (have used 'Properties'). And since I first enabled the GPU, requests for the GPU only get "Project has no jobs available" or "No work sent"

BTW I think this is my first Astropulse unit.

My machine rates the CPU at 726 floating MIPS, and my Nvidia 9600GT at 218 GFLOPS peak -- I dunno if those numbers can be compared to each other. But I only have two work units processing at a time, and I'm assuming the GPU is 'idle'.

Profile Gundolf Jahn
Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 361,386
RAC: 39
Germany
Message 989792 - Posted: 17 Apr 2010, 8:28:18 UTC - in response to Message 989789.
Last modified: 17 Apr 2010, 8:29:34 UTC

You can tell from the application name. If it contains 6.03, it's a CPU MultiBeam task; 6.08 and 6.09 are GPU (CUDA) tasks. There are no CUDA applications for AstroPulse.

However, there's no stock CUDA application for linux. So, if you want to use your GPU for SETI, you'll have to look in the Number crunching subforum for keywords like "optimized application" or "anonymous platform" [edit]or "lunatics"[/edit].

Gruß,
Gundolf
____________
Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

Questions and Answers : Getting started : Boinc will only run on the GPU and not my 4core CPU

Copyright © 2014 University of California