2 CUDA boards


log in

Advanced search

Questions and Answers : GPU applications : 2 CUDA boards

Author Message
Andrey Kissel'ov
Send message
Joined: 20 Sep 09
Posts: 5
Credit: 351,993
RAC: 0
Russia
Message 935846 - Posted: 25 Sep 2009, 16:16:44 UTC

Hi,collegs:)
On my comp is 2 CUDA boards: Tesla C870 and 8800 GTS. BOINC 6.6.36 select for job only 8800 GTS. But I want use Tesla in this case.
What think about?
Thanks!

Chuck Gorish
Send message
Joined: 19 Jun 00
Posts: 156
Credit: 29,589,106
RAC: 0
United States
Message 935887 - Posted: 25 Sep 2009, 20:24:42 UTC - in response to Message 935846.
Last modified: 25 Sep 2009, 20:31:25 UTC

Hi,collegs:)
On my comp is 2 CUDA boards: Tesla C870 and 8800 GTS. BOINC 6.6.36 select for job only 8800 GTS. But I want use Tesla in this case.
What think about?
Thanks!


upgrade to the latest 6.10.6 or 7 depending on your o/s and arch.

http://boinc.berkeley.edu/dl/?C=M;O=D

also your nvidia driver should be in the 185.18.x version range (i like .31) for cuda 2.2 and 190 series for cuda 2.3. i had some problems with 2.3 under linux but that is something on my system i am sure, since others use it just fine. i went back to 2.2.

6.6.36 does not know how to handle 2 devices properly. also in your boinc directory you should have a cc_config.xml that contains these statements:


<cc_config> <log_flags> <coproc_debug>1</coproc_debug> </log_flags> <options> <use_all_gpus>1</use_all_gpus> </options> </cc_config>


then in your setiathome project directory you should have a text file with no extension named "number_of_gpus" place a 2 as the only character in that file. that should get you on to processing with both.
____________

Andrey Kissel'ov
Send message
Joined: 20 Sep 09
Posts: 5
Credit: 351,993
RAC: 0
Russia
Message 935905 - Posted: 25 Sep 2009, 21:07:59 UTC - in response to Message 935887.

Ok, Chucky,
It runs both GPU now!

Chuck Gorish
Send message
Joined: 19 Jun 00
Posts: 156
Credit: 29,589,106
RAC: 0
United States
Message 935909 - Posted: 25 Sep 2009, 21:17:59 UTC - in response to Message 935905.

Ok, Chucky,
It runs both GPU now!


cool! :D


____________

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12396
Credit: 2,666,567
RAC: 800
Netherlands
Message 935940 - Posted: 26 Sep 2009, 1:12:04 UTC - in response to Message 935905.

Do know that the present BOINC 6.10 versions are development versions. A new version is released quite often, with bug-fixes, but also new bugs included. Today for instance we had two releases.

I am not saying you should update to each new version, but do keep an eye on the normal download page and upgrade as soon as you see 6.10 released to the general public.

Chuck Gorish wrote:
also in your boinc directory you should have a cc_config.xml

BOINC doesn't come with cc_config.xml, the core client configuration file, since it is primarily used for debugging only. You have to make it yourself. So don't just assume people have a cc_config.xml file and be prepared to tell them how to make one in case that's necessary.
____________
Jord

Fighting for the correct use of the apostrophe, together with Weird Al Yankovic

Andrey Kissel'ov
Send message
Joined: 20 Sep 09
Posts: 5
Credit: 351,993
RAC: 0
Russia
Message 935977 - Posted: 26 Sep 2009, 5:28:24 UTC - in response to Message 935940.

Yes.I made cc_config.xml by myself. Reboot BOINC. Second GPU ( Tesla C870, 19038 ) start works instantly. Power consump get high about 100-120W. ( 400-440 W whole machine )
Thanks, Jord.
But can I use Tesla only, without first NVIDIA 8800 ?

Chuck Gorish
Send message
Joined: 19 Jun 00
Posts: 156
Credit: 29,589,106
RAC: 0
United States
Message 935994 - Posted: 26 Sep 2009, 8:50:12 UTC - in response to Message 935977.

Yes.I made cc_config.xml by myself. Reboot BOINC. Second GPU ( Tesla C870, 19038 ) start works instantly. Power consump get high about 100-120W. ( 400-440 W whole machine )
Thanks, Jord.
But can I use Tesla only, without first NVIDIA 8800 ?


im not sure which one it is, but it should select only the most capable card if you either place the use_all_gpus to 0 in cc_config or change the 2 to a 1 in number_of_gpus. one of those i think the first allows boinc to use its default of choosing only the most capable card for cuda.


____________

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12396
Credit: 2,666,567
RAC: 800
Netherlands
Message 936010 - Posted: 26 Sep 2009, 11:14:20 UTC - in response to Message 935977.

But can I use Tesla only, without first NVIDIA 8800 ?

There is no option (yet) to choose which GPU(s) to use and which not.

Through cc_config.xml you can only set <no_gpus> (the no is NO, opposite of Yes. It does not stand for Numero aka Number). So setting <no_gpus>1</no_gpus> will disable all GPUs from even being detected on BOINC start-up.

You can also only set <use_all_gpus>, where if the value is 1 (one) for on, BOINC will use all the GPUs it has detected. If you disable this option (which it is by default), BOINC will use all but the first GPU by default. This is due to some problems in the detection API, which will make all GPUs in the computer show up as the same version, even if you have different versions in there. (So e.g. if you have an 8800 and a 9800, they'll all show as 8800s.)

So I guess, if you change the cards around inside your computer, putting the videocard in the primary PCIe slot and the Tesla in the secondary (or tertiary or whichever) slot, then start BOINC without the <use_all_gpus> option (set it to zero or remove the line from cc_config.xml, save the file, restart BOINC), that you can use the Tesla only. But that is really only a guess.


____________
Jord

Fighting for the correct use of the apostrophe, together with Weird Al Yankovic

Chuck Gorish
Send message
Joined: 19 Jun 00
Posts: 156
Credit: 29,589,106
RAC: 0
United States
Message 936037 - Posted: 26 Sep 2009, 14:42:33 UTC - in response to Message 936010.

But can I use Tesla only, without first NVIDIA 8800 ?

There is no option (yet) to choose which GPU(s) to use and which not.

So I guess, if you change the cards around inside your computer, putting the videocard in the primary PCIe slot and the Tesla in the secondary (or tertiary or whichever) slot, then start BOINC without the <use_all_gpus> option (set it to zero or remove the line from cc_config.xml, save the file, restart BOINC), that you can use the Tesla only. But that is really only a guess.



yeah when i set mine to 0 it chooses the tesla regardless of which slot it is in. if the tesla is in the first slot and my vid in second slot it still chose the tesla. i switched them and it still chose the tesla... the only difference is what it called them in its detection report so it may very well say 8800gt while it is using the tesla. only way to truly tell is look at the app in memory and see what device it is working with knowing that the card in slot 1 is device 0 and the card in slot 2 is device 1 which remains a constant... the device report in the msg log and what the seti computers listing shows is nothing but cosmetics and does not affect the operation of the system at all.

____________

tyj8tim
Send message
Joined: 14 Oct 09
Posts: 7
Credit: 7,603,685
RAC: 0
United States
Message 939777 - Posted: 14 Oct 2009, 8:29:16 UTC
Last modified: 14 Oct 2009, 8:43:10 UTC

hey all, i'm running 8800gt and 9400gt, bionic version 6.10 in win7 x64. i have the same problem that only 8800gt is using cuda calculation. i tried to make the cc_config.xml and the number_of_gpus files and that didn't work.. is that only for 6.6? what should i do so both gpu will work?

thanks.

Profile Gundolf Jahn
Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 360,556
RAC: 37
Germany
Message 939786 - Posted: 14 Oct 2009, 10:42:02 UTC - in response to Message 939777.

Where did you put the cc_config.xml file?

Did you see a message about it being read in Messages tab?

Gruß,
Gundolf
____________
Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

Questions and Answers : GPU applications : 2 CUDA boards

Copyright © 2014 University of California