Error - can't load library libcudart


log in

Advanced search

Questions and Answers : Macintosh : Error - can't load library libcudart

Author Message
Incognito
Send message
Joined: 7 Jan 00
Posts: 3
Credit: 341,657
RAC: 0
United States
Message 933595 - Posted: 15 Sep 2009, 22:07:18 UTC

I'm unable to get seti to run. The only error that I found was the title - can't load library libcudart.
What's going on?

thanks
Steve



Tue Sep 15 15:56:47 2009 Starting BOINC client version 6.6.36 for x86_64-apple-darwin
Tue Sep 15 15:56:47 2009 log flags: task, file_xfer, sched_ops
Tue Sep 15 15:56:47 2009 Libraries: libcurl/7.19.4 OpenSSL/0.9.7l zlib/1.2.3 c-ares/1.6.0
Tue Sep 15 15:56:47 2009 Data directory: /Library/Application Support/BOINC Data
Tue Sep 15 15:56:47 2009 Processor: 2 GenuineIntel Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz [x86 Family 6 Model 15 Stepping 11]
Tue Sep 15 15:56:47 2009 Processor features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM SSE3 MON DSCPL VMX EST TM2 SSSE3 CX16 TPR PDCM
Tue Sep 15 15:56:47 2009 OS: Darwin: 9.8.0
Tue Sep 15 15:56:47 2009 Memory: 2.00 GB physical, 243.53 GB virtual
Tue Sep 15 15:56:47 2009 Disk: 465.44 GB total, 243.28 GB free
Tue Sep 15 15:56:47 2009 Local time is UTC -6 hours
Tue Sep 15 15:56:47 2009 Can't load library libcudart
Tue Sep 15 15:56:47 2009 No coprocessors
Tue Sep 15 15:56:47 2009 Not using a proxy
Tue Sep 15 15:56:47 2009 SETI@home URL: http://setiathome.berkeley.edu/; Computer ID: 5107482; location: home; project prefs: default
Tue Sep 15 15:56:47 2009 SETI@home General prefs: from SETI@home (last modified 14-Sep-2009 16:55:50)
Tue Sep 15 15:56:47 2009 SETI@home Computer location: home
Tue Sep 15 15:56:47 2009 SETI@home General prefs: no separate prefs for home; using your defaults
Tue Sep 15 15:56:47 2009 Preferences limit memory usage when active to 1024.00MB
Tue Sep 15 15:56:47 2009 Preferences limit memory usage when idle to 1843.20MB
Tue Sep 15 15:56:47 2009 Preferences limit disk usage to 1.00GB
Tue Sep 15 15:56:48 2009 Suspending computation - user is active
Tue Sep 15 15:56:48 2009 Suspending network activity - user is active

____________

OzzFan
Volunteer tester
Avatar
Send message
Joined: 9 Apr 02
Posts: 13307
Credit: 27,854,856
RAC: 15,736
United States
Message 933623 - Posted: 15 Sep 2009, 23:38:45 UTC - in response to Message 933595.

That error message simply means that BOINC cannot load the nVidia CUDA library which isn't available on Macs as of yet (I believe support will be added with the next OS X release).

When I look in your account, I see that you have plenty of work. When I look at your messages you provided, it looks like you do not allow processing while the computer is in use:

Tue Sep 15 15:56:48 2009 Suspending computation - user is active
Tue Sep 15 15:56:48 2009 Suspending network activity - user is active


Are you sure it's not running when you're not using the computer?
____________

Incognito
Send message
Joined: 7 Jan 00
Posts: 3
Credit: 341,657
RAC: 0
United States
Message 933856 - Posted: 16 Sep 2009, 22:02:52 UTC - in response to Message 933623.

Hi,

I checked it's progress this morning and saw that it hadn't run overnight.
And I saw that it didn't run all day. A few minutes ago, I closed boinc manager (I don't run it as a service.) and restarted it. It started and was running up to when I checked now. I'll see if it starts up after the 10 min idle time now.

I don't let it run while the mac is in use. I also throttle it to 75% of cpu to keep the iMac from getting too hot.

I ran seti for about 10 yrs fairly regularly on a pc. I upgraded to a mac about a year ago.

Ideas?

Thanks,
Steve


____________

Profile arkayn
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3543
Credit: 46,149,306
RAC: 30,651
United States
Message 933979 - Posted: 17 Sep 2009, 7:50:21 UTC - in response to Message 933856.

I run my iMac at 100% all the time, but I do use smcFanControl to keep it cooler.
____________

Profile Costas Lazarides
Volunteer tester
Send message
Joined: 13 Jun 99
Posts: 2
Credit: 2,603,188
RAC: 1,092
Greece
Message 939174 - Posted: 11 Oct 2009, 15:15:37 UTC

New to Mac and have same problem as Incognito above. You mentioned that support will be added with the next OS X release. This is interesting. I somehow believed it had something to do with my Nvidia drivers although the GeForce 8800GS says it is supported on their site. Downloaded the relevant 'cudadriver_2_3_0.macos.pkg', the Developer and XCode tools and thought that would fix the problem, but it hasn't.

So, to get this straight, three factors have to be supported and work hand in hand for PCs to crunch on graphics cards like on my other two pcs: 1)the GPU with appropriate drivers, 2) The BOINC version, and finally 3) the operating system. So, in this case I should be patient till the appropriate OS version gets updated. I am currently on OS X 10.5.8. I would appreciate it if you let me know if I'm missing anything here.

Apple Mac OSX 10.5.8.
Intel Core 2 Duo CPU E8235 @ 2.80GHz [x86 FAmily 6 Model 23 Stepping 6]RAM 4GB
Disc 700GB

http://www.boincstats.com/signature/user_162677.gif
____________

Profile Gundolf Jahn
Send message
Joined: 19 Sep 00
Posts: 3184
Credit: 354,976
RAC: 22
Germany
Message 939184 - Posted: 11 Oct 2009, 16:05:55 UTC - in response to Message 939174.

http://www.boincstats.com/signature/user_162677.gif

Try [img]http://www.boincstats.com/signature/user_162677.gif[/img]:


Gruß,
Gundolf
____________
Computer sind nicht alles im Leben. (Kleiner Scherz)

SETI@home classic workunits 3,758
SETI@home classic CPU time 66,520 hours

Questions and Answers : Macintosh : Error - can't load library libcudart

Copyright © 2014 University of California