Cuda Units working on High priority


log in

Advanced search

Questions and Answers : GPU applications : Cuda Units working on High priority

Author Message
Profile Dorsilfin
Volunteer tester
Send message
Joined: 28 Jul 08
Posts: 69
Credit: 2,331,097
RAC: 0
United States
Message 841726 - Posted: 19 Dec 2008, 0:24:29 UTC

Since I started running the new Boinc version last night. All the WU's are running in High priority and are only downloading 20 at a time.

It isnt allowing me to que up more work then that, and I go through the stack of 20 very quickly.


Any suggestions?

Nighthawk[TECH]
Send message
Joined: 7 May 01
Posts: 4
Credit: 1,418,914
RAC: 0
Canada
Message 841745 - Posted: 19 Dec 2008, 1:05:28 UTC - in response to Message 841726.

I believe the issue lies in a poor estimation of how long each WU will take. Using the "show overall view" portion of BOINClogX shows completion estimates that range from 250hrs to 850hrs for regular MB workunits. Even though the estimate in BOINC manager says 0:00:00, I think the backend is using the estimates displayed by BOINClogX. The client then thinks that the WU are high priority because they will not be completed before the deadline, and promotes them, plus it refuses to get more work because it thinks it has plenty.

I don't have a solution, just an explanation, but I hope one is found soon, as S@H has taken over BOINC with these high-priority WU's and I am racking up huge LTD in my other projects.
____________

Profile Geek@PlayProject donor
Volunteer tester
Avatar
Send message
Joined: 31 Jul 01
Posts: 2464
Credit: 85,371,665
RAC: 18,302
United States
Message 841858 - Posted: 19 Dec 2008, 6:07:21 UTC
Last modified: 19 Dec 2008, 6:22:37 UTC

I have been using Boinc 6.4.5 to crunch down my cache in anticipation of installing a cuda enabled GPU. Boinc has been crunching in EDF mode for 48 hours now and this is without an NVIDIA GPU installed.

Something strange about this version of Boinc! The bad thing is that all the AP work is not being done because they are not due for 30 days or so.
____________
Boinc....Boinc....Boinc....Boinc....

Profile Euan Holton
Avatar
Send message
Joined: 4 Sep 99
Posts: 65
Credit: 13,186,480
RAC: 10,593
United Kingdom
Message 842219 - Posted: 19 Dec 2008, 21:47:30 UTC

Go to the list of your computers in your account, and check out the CUDA host's Task Duration Correction Factor. When I started processing CUDA units, mine got set to a very high level (100 I think, my main box running 'normal' optimised apps has a value of 0.14). That's the source of the problem, I think, as I believe that value is used as part of the calculations on how long it'll take to process each work unit.
____________

Profile Sergej O. S.
Volunteer tester
Send message
Joined: 29 Oct 08
Posts: 123
Credit: 44,886
RAC: 0
Russia
Message 842622 - Posted: 20 Dec 2008, 18:50:30 UTC - in response to Message 842219.

Thanks. So, I totally exit BOINC and changed <duration_correction_factor>81.168666 in my client_state.xml file to 0.3 (guessed time for unptimized applications on my Q6600) and now BOINC work in usual priority and even got new yummu tasks.
____________

Profile Byron S Goodgame
Volunteer tester
Avatar
Send message
Joined: 16 Jan 06
Posts: 1151
Credit: 3,936,993
RAC: 0
United States
Message 842643 - Posted: 20 Dec 2008, 19:14:42 UTC - in response to Message 842622.

Thanks for that, did the same and worked the same. Times are much closer to what is normal and am no longer in high priority.
____________

Questions and Answers : GPU applications : Cuda Units working on High priority

Copyright © 2014 University of California