error: 'i586-pc-lunux-gnu' not found


log in

Advanced search

Questions and Answers : Unix/Linux : error: 'i586-pc-lunux-gnu' not found

Author Message
john.b
Send message
Joined: 4 Apr 06
Posts: 6
Credit: 9,276
RAC: 0
Netherlands
Message 807751 - Posted: 13 Sep 2008, 12:49:02 UTC

Hi,
I installed a new version of Sabayon linux (3.5) and started using Boinc again. I got the same error as when I first started to use Boinc on an older version of Sabayon 5 months back saying that the i586 platform was not recognized.
The previous issue was solved by adjusting the make.conf (Thread can be found here: http://setiathome.berkeley.edu/forum_thread.php?id=47135):
"ACCEPT_KEYWORDS="x86"
(if you want an unstable ~x86 package, add it to the package.keywords file)

CBUILD="i686-pc-linux-gnu"
CHOST="i686-pc-linux-gnu"
(changing this might break the system, but works mostly fine)

CFLAGS="-O2 -march=pentium4 -mno-tls-direct-seg-refs"
CXXFLAGS="${CFLAGS}"

I tried the same trick but alas, the same error message keeps popping up.

Can somebody assist please?
I'll post my emerge --info here.

Txs,
John

------------------------------------------------------
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.2.3, glibc-2.7-r1, 2.6.25-sabayon-r1 i686)
=================================================================
System uname: 2.6.25-sabayon-r1 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz
Timestamp of tree: Fri, 12 Sep 2008 17:00:01 +0000
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash: 3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python: 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.2.5-r1
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.62
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils: 2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -mno-tls-direct-seg-refs"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -mno-tls-direct-seg-refs"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="nl_NL.UTF-8"
LC_ALL="nl_NL.UTF-8"
LINGUAS="nl"
MAKEOPTS="-j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sabayon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dfx 7Zip X a52 aac aalib accessibility acl acpi aiglx aim alsa artswrappersuid asf audiofile avahi berkdb bidi bluetooth bzip2 cairo cdda cddb cdr chm cjk cli commercial config_wizard cpudetection cracklib crypt css cups dbox2 dbus device-mapper dga dri dts dv dvb dvd dvdr dvdread dvi dxr3 encode exscalibar extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint gnutls gphoto2 gpm gs gsm gstreamer gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda isdnlog jabber jack jfs jingle joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kickoff kipi lame lcd libao libnotify live lj lm_sensors logitech-mouse lzo mad mail midi mikmod mjpeg mmx mng mozdevelop mp3 mp3rtp mpeg msn mudflap musepack musicbrainz ncurses network new-login nls nptl nptlonly nsplugin ntfs ogg openal openexr opengl openmp pam pcmcia pcre pda perl png povray ppds pppd pulseaudio pwdb python qt3 qt3support qt4 quotas rar rdesktop readline real reflection reiserfs rss scanner sdl session slp sms speex spell spl spreadsheet ssl startup-notification stream svg switch_all_desktops sysfs tcpd theora tiff tracker truetype udev unicode usb v4l v4l2 visualization voice vorbis weather wifi win32codecs wmf x264 x86 xcb xfs xine xinerama xml xorg xpm xprint xulrunner xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl" LIRC_DEVICES="audio audio_alsa" USERLAND="GNU"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Txs,
John
____________

Dotsch
Volunteer tester
Avatar
Send message
Joined: 9 Jun 99
Posts: 2422
Credit: 848,518
RAC: 11
Germany
Message 807757 - Posted: 13 Sep 2008, 13:40:03 UTC
Last modified: 13 Sep 2008, 13:43:56 UTC

Why not installing a offical BOINC client version from boinc.berkeley.edu/download.php ?
So far I know is i686 or i386 the right platform.

You can also install the SETI application manualy. It's described in this posting for SETI 5.27, but 6.03 would work on the same way : http://setiathome.berkeley.edu/forum_thread.php?id=48957&nowrap=true#801247

Desti
Volunteer tester
Send message
Joined: 28 Feb 03
Posts: 123
Credit: 306,694
RAC: 0
Message 808131 - Posted: 14 Sep 2008, 17:24:38 UTC

This Sabayon linux is similar to Gentoo linux?

What gcc do you have installed? Check please gcc -v the target platform.
If you have changed the make.conf, you need first run env-update before you can compile new apps with the new settings in the same shell.
____________

Questions and Answers : Unix/Linux : error: 'i586-pc-lunux-gnu' not found

Copyright © 2014 University of California