Astropulse binaries for other platforms


log in

Advanced search

Questions and Answers : Macintosh : Astropulse binaries for other platforms

Previous · 1 · 2 · 3 · 4 · Next
Author Message
Dotsch
Volunteer tester
Avatar
Send message
Joined: 9 Jun 99
Posts: 2422
Credit: 843,228
RAC: 27
Germany
Message 910813 - Posted: 24 Jun 2009, 19:08:01 UTC

I have released a Astropulse 5.05 application for MacOS Intel and PPC.

Dotsch
Volunteer tester
Avatar
Send message
Joined: 9 Jun 99
Posts: 2422
Credit: 843,228
RAC: 27
Germany
Message 953557 - Posted: 10 Dec 2009, 8:32:27 UTC
Last modified: 10 Dec 2009, 8:32:52 UTC

I've released Astropulse 5.06 binaries for MacOS 10.4x and 10.5.x on Intel and PowerPC.

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 953786 - Posted: 11 Dec 2009, 5:07:14 UTC - in response to Message 953557.
Last modified: 11 Dec 2009, 5:07:54 UTC

Installed this (5.06) tonight with your included installer. All appeared to go well - no errors. Restarted BOINC, and instead of running like a good little program the silly thing keeps trying to download astropulse_5.03_powerpc-apple-darwin.

Thoughts appreciated.
____________
John

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12131
Credit: 2,525,065
RAC: 551
Netherlands
Message 953799 - Posted: 11 Dec 2009, 7:01:56 UTC - in response to Message 953786.

That usually happens when you misplace the app_info.xml file. Make sure it is in your \BOINC\projects\setiathome.berkeley.edu\ directory and that it contains the correct information about the optimized application you want to use.
____________
Jord

Loving awareness is free.

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 953806 - Posted: 11 Dec 2009, 7:21:05 UTC - in response to Message 953799.
Last modified: 11 Dec 2009, 7:22:12 UTC

Interesting. Given that I used the installer, rather than do it manually, I ass-umed all would be well. :-)

The file you mentioned is in the folder, and I have made no changes to it I'm a ColdFusion guy, not XML). Should I remove the <app> - </app-version> statements in the middle of the file that refer to astropulse_v5 and astropulse_5.03_powerpc-apple-darwin?

I also noticed that the last chunk appears to need an update...

<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>astropulse_5.06_powerpc-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<file_ref>
<file_name>astropulse_5.06_powerpc-apple-darwin</file_name>
<main_program/>
</file_ref>
</app_version>


<app><name> refers to v505, while <file_info><name> refers to 5.06. Or doesn't that matter.

Thanks.
____________
John

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12131
Credit: 2,525,065
RAC: 551
Netherlands
Message 953809 - Posted: 11 Dec 2009, 7:36:30 UTC - in response to Message 953806.

It's not real XML, more like a script. Can you post your complete app_info.xml file? Perhaps that there's something amiss around the 5.03 app.

Don't remove anything at this time.
____________
Jord

Loving awareness is free.

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 954069 - Posted: 12 Dec 2009, 2:00:46 UTC - in response to Message 953809.

As requested...

<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>setiathome_6.03_powerpc-apple-darwin</name>
<executable/>
</file_info>
<file_info>
<name>setigraphics_6.03_powerpc-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<file_ref>
<file_name>setiathome_6.03_powerpc-apple-darwin</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>setigraphics_6.03_powerpc-apple-darwin</file_name>
<open_name>graphics_app</open_name>
</file_ref>
</app_version>

<app>
<name>astropulse_v5</name>
</app>
<file_info>
<name>astropulse_5.03_powerpc-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v5</app_name>
<version_num>503</version_num>
<file_ref>
<file_name>astropulse_5.03_powerpc-apple-darwin</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v505</name>
</app>
<file_info>
<name>astropulse_5.06_powerpc-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v505</app_name>
<version_num>505</version_num>
<file_ref>
<file_name>astropulse_5.06_powerpc-apple-darwin</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

Thanks.
____________
John

Profile arkayn
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3545
Credit: 46,343,873
RAC: 30,986
United States
Message 954091 - Posted: 12 Dec 2009, 3:09:27 UTC
Last modified: 12 Dec 2009, 3:11:45 UTC

I think I understand now, he never had the v5 AP app before and the app_info is referencing it so it is trying to download the app from SETI.

All of his other work is listed under the correct application until he downloaded his most recent which is listed as anonymous.

I just updated my app packages with the newer v505 build and I have removed the v5 app since there is pretty much nothing left of them.

http://www.arkayn.us/seti/OSX_V8_AP5_G5.zip
That one has Alex Kans optimized app for the G5 along with Dotsch's new AP build and a updated app_info.

And if you want on the PC, the unified installer for x86.
http://www.arkayn.us/seti/Lunatics_Win32v0.2_AP505r168_AKv8b_CudaV12.exe
____________

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 954111 - Posted: 12 Dec 2009, 3:59:51 UTC - in response to Message 954091.

OK - done, and up and running. Now to wait for an AP.

Sorry 'bout not giving better/more info on exactly what the situation was here. Some age-related problem, no doubt!

Thanks very much, folks!

____________
John

Profile Ageless
Avatar
Send message
Joined: 9 Jun 99
Posts: 12131
Credit: 2,525,065
RAC: 551
Netherlands
Message 954136 - Posted: 12 Dec 2009, 8:23:13 UTC - in response to Message 954111.

I have checked what's in the 5.06 tar.gz archive that Dotsch provides. There is only the app_info.xml and the 5.06 binary in there, even though the 5.03 archive is pointed to in the app_info.xml file.

Since the stock Seti Astropulse v5 applications 5.03 are not available for the Mac PowerPC, I have emailed Dotsch that he should either provide the binary in the archive, or not point at it at all in the app_info.xml file.
____________
Jord

Loving awareness is free.

Dotsch
Volunteer tester
Avatar
Send message
Joined: 9 Jun 99
Posts: 2422
Credit: 843,228
RAC: 27
Germany
Message 954152 - Posted: 12 Dec 2009, 11:17:07 UTC
Last modified: 12 Dec 2009, 11:17:45 UTC

I am very sorry for the troubles !

I thought, that the users has already installed the AP 5.03 application, so I bundled 5.03 together with 5.06 in one app_info.xml.

John, you can also download AP 5.03 from my homepage and copy the AP 5.03 binary to the project folder and "sudo chown boinc_master:boinc_project the binaries in the project folders.

I will think about a reliable solution for the problem.

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 954204 - Posted: 12 Dec 2009, 16:48:04 UTC - in response to Message 954152.

I am very sorry for the troubles !

No problem. As mentioned, my fault for not being more complete in my description.

John, you can also download AP 5.03 from my homepage and copy the AP 5.03 binary to the project folder and "sudo chown boinc_master:boinc_project the binaries in the project folders.

Is 5.03 necessary, now that 5.06 is happily in place where it belongs?

Thanks.

____________
John

Profile arkayn
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3545
Credit: 46,343,873
RAC: 30,986
United States
Message 954295 - Posted: 13 Dec 2009, 0:08:33 UTC - in response to Message 954204.
Last modified: 13 Dec 2009, 0:12:50 UTC

Nope, they are not producing any more AP v5 units, just AP v505.
____________

Profile John Gillett
Avatar
Send message
Joined: 26 May 99
Posts: 52
Credit: 8,398,169
RAC: 21,579
United States
Message 958643 - Posted: 25 Dec 2009, 3:04:00 UTC

Completed my first AP unit today (~90 hours). All seemed to go well.

Thanks again.

____________
John

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1080
Credit: 31,111,053
RAC: 85,071
United States
Message 1301171 - Posted: 2 Nov 2012, 5:40:43 UTC

I just ran into a similar problem on a 2008 MacPro with 10.6.8. I was looking for some way to speed up Astropulse and installed the files from here http://lunatics.kwsn.net/index.php?module=Downloads;catd=30 I had the normal Seti 6.0x & Astropulse installed already. I first ran the ap_install.command for the x32 version then realized I needed the x64 version after restarting Boinc and seeing it downloading WUs. I shut it down again and ran the x64 bit version. After restarting Boinc I noticed a few things. It was downloading WUs but none of the old WUs were listed. They are still in the /Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu folder, but the old Apps are missing. After the old WUs the folder contains,
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_6.02r561_OSX32
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_6.02r561_OSX64
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_08se12ae_B4_P0_00337_20121029_03784.wu
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_08se12ae_B4_P0_00337_20121029_03784.wu_1_0
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_08se12ae_B5_P1_00109_20121029_06405.wu
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/ap_08se12ae_B5_P1_00109_20121029_06405.wu_1_0
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/app_info.xml
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/arecibo_181.png
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/sah_40.png
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/sah_banner_290.png
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/sah_ss_290.png
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/slideshow_setiathome_enhanced_00
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/slideshow_setiathome_enhanced_01
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/slideshow_setiathome_enhanced_02
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/stat_icon
/Library/Application Support/BOINC Data/projects/setiathome.berkeley.edu/wisdom.dat

It seems to be working fine running the ap_6.02r561_OSX64, but, I'd really like to get the other Apps back and not lose the old work units. I'm guessing I need to add the Seti 6.0x & old Astropulse Apps to the app_info.xml file and then it will download those Apps again? The current app_info.xml files reads;
<app_info>
<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>ap_6.02r561_OSX64</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>602</version_num>
<file_ref>
<file_name>ap_6.02r561_OSX64</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

The stdoutdae.txt file is loaded with nasty comments like "No application found for task: i686-apple-darwin 602 ; discarding"
"Can't handle workunit in state file State file error: missing application setiathome_enhanced"
"Can't link task 26se12ac.17406.301829.140733193388046.10.152_0 in state file State file error: missing task 26se12ad.16830.7838.140733193388039.10.65"
And my favorite it just posted, "Your app_info.xml file doesn't have a usable version of SETI@home Enhanced".

Any way someone can post what I should add to the app_info.xml file? I'm afraid to do anything at this point.
TIA.

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1080
Credit: 31,111,053
RAC: 85,071
United States
Message 1301340 - Posted: 2 Nov 2012, 18:11:16 UTC - in response to Message 1301171.

Well, I went back and found what would appear to be the correct app name from the stdoutdae.txt file ;
13-Oct-2012 06:51:52 [SETI@home] Finished download of setiathome_6.05_i686-apple-darwin
That app is missing so, I had to look at the log. I'm also missing 17-Oct-2012 11:13:10 [SETI@home] Finished download of astropulse_6.02_i686-apple-darwin, but, I decided to take it one step at a time. I used Dashcode to edit the app_info.xml to read;
<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>setiathome_6.05_i686-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>605</version_num>
<file_ref>
<file_name>setiathome_6.05_i686-apple-darwin</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>ap_6.02r561_OSX64</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>602</version_num>
<file_ref>
<file_name>ap_6.02r561_OSX64</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

Then ran the Boinc installer to fix the permissions. Boinc launched and quickly said;
02-Nov-2012 13:12:29 [SETI@home] Found app_info.xml; using anonymous platform
02-Nov-2012 13:12:29 [SETI@home] File referenced in app_info.xml does not exist: setiathome_6.05_i686-apple-darwin
02-Nov-2012 13:12:29 [SETI@home] State file error: missing application file setiathome_6.05_i686-apple-darwin

I still need to add the astropulse_6.02_i686-apple-darwin at some point. It's still crunching the ap_6.02r561_OSX64 files at present.

Suggestions?

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1080
Credit: 31,111,053
RAC: 85,071
United States
Message 1301413 - Posted: 2 Nov 2012, 21:08:23 UTC - in response to Message 1301340.

This is the log from when I shut it down, ran the ap_install.command from the ap_6.02r561_OSX32 app, and then restarted;
01-Nov-2012 18:26:57 [SETI@home] Computation for task 26se12ad.16830.7838.140733193388039.10.160_1 finished
01-Nov-2012 18:26:57 [SETI@home] Starting task 26se12ad.16830.8656.140733193388039.10.187_1 using setiathome_enhanced version 605 in slot 2
01-Nov-2012 18:26:59 [SETI@home] Started upload of 26se12ad.16830.7838.140733193388039.10.160_1_0
01-Nov-2012 18:27:35 [SETI@home] Finished upload of 26se12ad.16830.7838.140733193388039.10.160_1_0
01-Nov-2012 18:33:42 [---] Exit requested by user
01-Nov-2012 18:36:05 [---] No config file found - using defaults
01-Nov-2012 18:36:05 [---] Starting BOINC client version 7.0.31 for x86_64-apple-darwin
01-Nov-2012 18:36:05 [---] log flags: file_xfer, sched_ops, task
01-Nov-2012 18:36:05 [---] Libraries: libcurl/7.26.0 OpenSSL/0.9.7l zlib/1.2.3 c-ares/1.9.1
01-Nov-2012 18:36:05 [---] Data directory: /Library/Application Support/BOINC Data
01-Nov-2012 18:36:05 [---] Processor: 4 GenuineIntel Intel(R) Xeon(R) CPU E5462 @ 2.80GHz [x86 Family 6 Model 23 Stepping 6]
01-Nov-2012 18:36:05 [---] Processor features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 DTES64 MON DSCPL VMX EST TM2 SSSE3 CX16 TPR PDCM SSE4.1
01-Nov-2012 18:36:05 [---] OS: Mac OS X 10.6.8 (Darwin 10.8.0)
01-Nov-2012 18:36:05 [---] Memory: 6.00 GB physical, 114.22 GB virtual
01-Nov-2012 18:36:05 [---] Disk: 186.27 GB total, 113.97 GB free
01-Nov-2012 18:36:05 [---] Local time is UTC -4 hours
01-Nov-2012 18:36:05 [---] OpenCL: NVIDIA GPU 0: GeForce 8800 GT (driver version CLH 1.0, device version OpenCL 1.0, 512MB, 512MB available)
01-Nov-2012 18:36:05 [---] OpenCL: ATI GPU 0: ATI Radeon BB Prototype (driver version 1.0, device version OpenCL 1.0, 1024MB, 1024MB available)
01-Nov-2012 18:36:05 [SETI@home] Found app_info.xml; using anonymous platform
01-Nov-2012 18:36:05 [SETI@home] State file error: missing application setiathome_enhanced
01-Nov-2012 18:36:05 [SETI@home] Can't handle workunit in state file
There are a lot of the above 2 lines, then a lot of the lines;
01-Nov-2012 18:36:05 [SETI@home] State file error: missing task 26se12ad.16830.7838.140733193388039.10.160
01-Nov-2012 18:36:05 [SETI@home] Can't link task 26se12ad.16830.7838.140733193388039.10.160_1 in state file
Then;
01-Nov-2012 18:36:05 [SETI@home] URL http://setiathome.berkeley.edu/; Computer ID 6796479; resource share 100
01-Nov-2012 18:36:05 [SETI@home] General prefs: from SETI@home (last modified 13-Oct-2012 21:46:00)
01-Nov-2012 18:36:05 [SETI@home] Host location: none
01-Nov-2012 18:36:05 [SETI@home] General prefs: using your defaults
01-Nov-2012 18:36:05 [---] Reading preferences override file
01-Nov-2012 18:36:05 [---] Preferences:
01-Nov-2012 18:36:05 [---] max memory usage when active: 3072.00MB
01-Nov-2012 18:36:05 [---] max memory usage when idle: 5529.60MB
01-Nov-2012 18:36:05 [---] max disk usage: 10.00GB
01-Nov-2012 18:36:05 [---] max CPUs used: 3
01-Nov-2012 18:36:05 [---] suspend work if non-BOINC CPU load exceeds 40 %
01-Nov-2012 18:36:05 [---] (to change preferences, visit the web site of an attached project, or select Preferences in the Manager)
01-Nov-2012 18:36:05 [---] Not using a proxy
Initialization completed
01-Nov-2012 18:36:06 [SETI@home] Sending scheduler request: To fetch work.
01-Nov-2012 18:36:06 [SETI@home] Requesting new tasks for CPU
01-Nov-2012 18:36:16 [SETI@home] Scheduler request completed: got 3 new tasks
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ad.16830.7838.140733193388039.10.65_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ac.17406.301829.140733193388046.10.152_0 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ad.16830.7838.140733193388039.10.160_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ad.16830.8656.140733193388039.10.187_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ac.16668.306737.140733193388045.10.91_0 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ad.9500.4259.140733193388040.10.69_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Resent lost task ap_08se12ae_B4_P0_00337_20121029_03784.wu_1
01-Nov-2012 18:36:16 [SETI@home] Resent lost task ap_08se12ae_B5_P1_00109_20121029_06405.wu_1
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 26se12ad.3727.11110.140733193388042.10.128_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Didn't resend lost task 27se12ac.3886.309918.140733193388035.10.50_1 (expired)
01-Nov-2012 18:36:16 [SETI@home] Resent lost task ap_02oc12ac_B0_P0_00308_20121029_02524.wu_1
01-Nov-2012 18:36:18 [SETI@home] Started download of ap_08se12ae_B4_P0_00337_20121029_03784.wu
01-Nov-2012 18:36:18 [SETI@home] Started download of ap_08se12ae_B5_P1_00109_20121029_06405.wu
01-Nov-2012 18:37:47 [---] Project communication failed: attempting access to reference site
01-Nov-2012 18:37:47 [SETI@home] Temporarily failed download of ap_08se12ae_B4_P0_00337_20121029_03784.wu: transient HTTP error
01-Nov-2012 18:37:47 [SETI@home] Backing off 3 min 15 sec on download of ap_08se12ae_B4_P0_00337_20121029_03784.wu
01-Nov-2012 18:37:47 [SETI@home] Started download of ap_02oc12ac_B0_P0_00308_20121029_02524.wu
01-Nov-2012 18:37:48 [---] Internet access OK - project servers may be temporarily down.
01-Nov-2012 18:40:14 [---] Exit requested by user

Whatever happened, it was when I ran the 32 bit Install script. My startup disk is a RAID 0 volume, Disk Description: Apple RAID, Set Name: Snow Leopard, RAID Status: Online, Type: Striped RAID Set, Number of Slices: 2, Version: AppleRAID version 2.0. Just in case that makes a difference...

Profile arkayn
Volunteer tester
Avatar
Send message
Joined: 14 May 99
Posts: 3545
Credit: 46,343,873
RAC: 30,986
United States
Message 1301497 - Posted: 3 Nov 2012, 0:21:10 UTC - in response to Message 1301413.

You might also try this package which has the AP app along with the Multibeam app.
http://www.arkayn.us/forum/index.php?action=tpmod;dl=item64
____________

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1080
Credit: 31,111,053
RAC: 85,071
United States
Message 1301565 - Posted: 3 Nov 2012, 4:42:04 UTC - in response to Message 1301497.

I installed the seti_enhanced-v8-xeon app and edited the app_info.xml file to;
<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>seti_enhanced-v8-xeon</name>
<executable/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>603</version_num>
<file_ref>
<file_name>seti_enhanced-v8-xeon</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v6</name>
</app>
<file_info>
<name>ap_6.02r561_OSX64</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6</app_name>
<version_num>602</version_num>
<file_ref>
<file_name>ap_6.02r561_OSX64</file_name>
<main_program/>
</file_ref>
</app_version>

<app>
<name>astropulse_v6.02</name>
</app>
<file_info>
<name>astropulse_6.02_i686-apple-darwin</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse_v6.02</app_name>
<version_num>602</version_num>
<file_ref>
<file_name>astropulse_6.02_i686-apple-darwin</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

I then got;
02-Nov-2012 22:45:01 [SETI@home] Found app_info.xml; using anonymous platform
02-Nov-2012 22:45:01 [SETI@home] File referenced in app_info.xml does not exist: astropulse_6.02_i686-apple-darwin
02-Nov-2012 22:45:01 [SETI@home] State file error: missing application file astropulse_6.02_i686-apple-darwin

The only tasks listed are the three remaining CPU APs it's working on. It looks like more than just the two apps got vaporized. I'm also missing these files as well;
17-Oct-2012 11:11:55 [SETI@home] Started download of astropulse_6.02_i686-apple-darwin
17-Oct-2012 11:11:55 [SETI@home] Started download of astropulse_6.02_AUTHORS
17-Oct-2012 11:11:57 [SETI@home] Finished download of astropulse_6.02_AUTHORS
17-Oct-2012 11:11:57 [SETI@home] Started download of astropulse_6.02_COPYING
17-Oct-2012 11:11:59 [SETI@home] Finished download of astropulse_6.02_COPYING
17-Oct-2012 11:11:59 [SETI@home] Started download of astropulse_6.02_COPYRIGHT
17-Oct-2012 11:12:00 [SETI@home] Finished download of astropulse_6.02_COPYRIGHT
17-Oct-2012 11:12:00 [SETI@home] Started download of ap_graphics_6.02_i686-apple-darwin
17-Oct-2012 11:13:10 [SETI@home] Finished download of astropulse_6.02_i686-apple-darwin
17-Oct-2012 11:13:10 [SETI@home] Started download of ap_602.jpg
17-Oct-2012 11:13:11 [SETI@home] Finished download of ap_602.jpg
17-Oct-2012 11:13:11 [SETI@home] Started download of ap_25my12ad_B3_P0_00201_20120922_29807.wu
17-Oct-2012 11:13:33 [SETI@home] Finished download of ap_graphics_6.02_i686-apple-darwin

After reading these, http://www.boinc-wiki.info/WU_refers_to_nonexistent_app:_%27(app_name)%27 & http://www.boinc-wiki.info/WU_refers_to_nonexistent_app_version:_%27(app-name)%27_%27(version)%27 I think it's best just to hit the reset button. At least I know how to edit the app_info.xml file now and can setup the optimized apps after the reset. As soon as the 3 APs are completed I'm going to reset the project.

TBar
Volunteer tester
Send message
Joined: 22 May 99
Posts: 1080
Credit: 31,111,053
RAC: 85,071
United States
Message 1301769 - Posted: 3 Nov 2012, 18:27:22 UTC - in response to Message 1301497.

You might also try this package which has the AP app along with the Multibeam app.
http://www.arkayn.us/forum/index.php?action=tpmod;dl=item64

Whoa, that seti_enhanced-v8-xeon app is something else. The WUs estimated at 4 hours are being completed in 27 minutes. It appears to be valid too :) That's a heck of a difference. That's good because, the Reset Project button wasn't what I expected. I thought it would reset everything and at least download the missing seti enhanced darwin version. The only thing it downloaded was images. I guess it doesn't matter now, although it would be nice to get the Darwin Astropulse app back.

What kind of results do you think I'd get using the Linux version here http://www.arkayn.us/forum/index.php?action=tpmod;dl=item52 on my Dell P4 with Ubuntu? I started out with plans to run seti on the Ubuntu Dell but gave up when Ubuntu refused to recognize the Ancient ATI 9600 or install the latest version of Boinc. Every time I downloaded the Boinc update it would hang gedit for minutes and then finally say there was something wrong with the file. I managed to trash a few WUs trying to update Boinc. It's taking about 11 hours per unit with the stock seti on the Dell.

Thanks for the Xeon Seti app, it's much better.

Previous · 1 · 2 · 3 · 4 · Next
Post to thread

Questions and Answers : Macintosh : Astropulse binaries for other platforms

Copyright © 2014 University of California