Computer Location not working

Questions and Answers : Preferences : Computer Location not working

To post messages, you must log in.

AuthorMessage
Profile huns0004

Send message
Joined: 14 Jun 01
Posts: 46
Credit: 2,596,674
RAC: 2,314
United States
Message 15453 - Posted: 11 Aug 2004, 13:38:25 UTC

I am having a problem with the computer location setting. My computer set to "Work" keeps on reverting to "Home," no matter how many times I try to update it from this website. Also, when I click on "Update" in the BOINC client at work, it doesn't use the separate preferences for work, it just says it is "using your defaults." The separate preferences use to work for me, this is something that just started recently.

ID: 15453 · Report as offensive
Profile Toby
Volunteer tester
Avatar

Send message
Joined: 26 Oct 00
Posts: 1005
Credit: 6,366,949
RAC: 0
United States
Message 16244 - Posted: 22 Aug 2004, 2:38:08 UTC

I'm having the same problem. I decided to set up some 'work' preferences which would casue the client to only cache 0.2 days worth of work so that I don't dump a bunch of work units when I want to detach a computer from a project for some reason. But I can't get my computer changed from its default location to 'work'. I would rather not change the 'home' preferences since that would change all my computers.



-------------------------------------------
- A member of The Knights Who Say NI!
Possibly the best stats site in the universe:
http://boinc-kwsn.no-ip.info

ID: 16244 · Report as offensive
[B^S] iimotion
Volunteer tester
Avatar

Send message
Joined: 25 Nov 01
Posts: 25
Credit: 384,195
RAC: 0
Germany
Message 17857 - Posted: 26 Aug 2004, 16:28:08 UTC
Last modified: 6 Sep 2004, 15:52:04 UTC

All user profile/preferences updates between August 13th and 18th were lost due to systemcrash. It might be that you have to update your profile/preferences.

ID: 17857 · Report as offensive
Roelof

Send message
Joined: 9 Jan 00
Posts: 9
Credit: 542,378
RAC: 0
Netherlands
Message 17955 - Posted: 26 Aug 2004, 21:35:37 UTC - in response to Message 17857.

> All user profile/preferences updates between August 13th and 18th were lost
> due to systemcrash. It might be that you have to update your
> profile/preferences.

No, it's not that. Every time you change the computer location, on your preferences-web-page for a computer, it looks like it is accepted (as you can check by updating the preferences on the client), but the next time you get the web-page, it always shows "Home" for the location.
If you change preferences, you have to set the location again, as the web-page always resets it, and also stores it if you save the changes.

ID: 17955 · Report as offensive
Profile Jason L. Allerdings

Send message
Joined: 21 May 99
Posts: 8
Credit: 42,287
RAC: 0
United States
Message 18221 - Posted: 27 Aug 2004, 14:53:27 UTC - in response to Message 17955.

> > All user profile/preferences updates between August 13th and 18th were
> lost
> > due to systemcrash. It might be that you have to update your
> > profile/preferences.
>
> No, it's not that. Every time you change the computer location, on your
> preferences-web-page for a computer, it looks like it is accepted (as you can
> check by updating the preferences on the client), but the next time you get
> the web-page, it always shows "Home" for the location.
> If you change preferences, you have to set the location again, as the web-page
> always resets it, and also stores it if you save the changes.
>
>
>

I've noticed that it does retain the location on the computer web page until the client on that computer calls the server to upload/download and update information, then the location on the web page is reset to the home location.

ID: 18221 · Report as offensive
Jeff

Send message
Joined: 6 Oct 99
Posts: 8
Credit: 4,627,693
RAC: 0
United States
Message 23792 - Posted: 8 Sep 2004, 18:35:55 UTC - in response to Message 16244.

> I'm having the same problem. I decided to set up some 'work' preferences
> which would casue the client to only cache 0.2 days worth of work so that I
> don't dump a bunch of work units when I want to detach a computer from a
> project for some reason. But I can't get my computer changed from its default
> location to 'work'. I would rather not change the 'home' preferences since
> that would change all my computers.

I'm also having the same problem, but even when I change the "home" preferences, the settings still don't work. In my case I'm attempting to set "Do work while computer is in use" to "no" because even at low priority BOINC is taking half of my hyperthreaded p4 away from my foreground apps.

ID: 23792 · Report as offensive
Urban

Send message
Joined: 4 Jan 00
Posts: 26
Credit: 835,395
RAC: 1
Germany
Message 24474 - Posted: 10 Sep 2004, 11:07:51 UTC - in response to Message 16244.

All,

I've found a solution, better a hack for these Problem.

1. Exit the complete bionc_gui, it's a must!!!
2. edit the file client_state.xml in the BOINC installation directory.
3. go at the end and change eg. home into work save it
4. start boinc again and after an update Your Computer is set to work

Good luck
Urban

ID: 24474 · Report as offensive
Urban

Send message
Joined: 4 Jan 00
Posts: 26
Credit: 835,395
RAC: 1
Germany
Message 24479 - Posted: 10 Sep 2004, 11:39:08 UTC - in response to Message 24474.

> All,
>
> I've found a solution, better a hack for these Problem.
>
> 1. Exit the complete bionc_gui, it's a must!!!
> 2. edit the file client_state.xml in the BOINC installation directory.
> 3. go at the end and change eg. home into work save it
> 4. start boinc again and after an update Your Computer is set to work
>
> Good luck
> Urban
>
>
I found on an other Computer that the mentioned line 3. isn't there. If Your are at the end of the file and the line

home

isn't there, then just add these one before the line



You can then store for the value home also work or school.

@the Boinc Developers/HelpDesk my guess is, that the "master" for that Value is not the WebSite it's the Client self and a change of that Value will NOT be stored there!


ID: 24479 · Report as offensive
Urban

Send message
Joined: 4 Jan 00
Posts: 26
Credit: 835,395
RAC: 1
Germany
Message 25839 - Posted: 13 Sep 2004, 8:43:29 UTC

After I read my post I saw that the XML Commands are now hidden :-(

I replace now the with )

Here the needed line:

(host_venue)work(/host_venue)

These line should just before the Line

(/client_state)

My understanding is that only the host_venue line controls, which type the client is, the Web Settings are not passed to the client.


ID: 25839 · Report as offensive

Questions and Answers : Preferences : Computer Location not working


 
©2016 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.