Why so slow? What to do?


log in

Advanced search

Questions and Answers : Unix/Linux : Why so slow? What to do?

Author Message
Tye W. Botting
Volunteer tester
Send message
Joined: 7 Jan 00
Posts: 11
Credit: 53,631,311
RAC: 0
United States
Message 9826 - Posted: 19 Jul 2004, 15:43:40 UTC

The linux client is now almost twice as slow per WU as the windows client. In beta, the linux client was just a tad faster.

I don't like wasting all the possible crunching power and haven't had luck with running the windows boinc_cli.exe under windows.

So, is there any other solution to get the linux client more up to speed? As it is, it's almost not worth running the client if you've got linux boxen. Argh.

Profile xi3piscium
Volunteer tester
Avatar
Send message
Joined: 17 Aug 99
Posts: 287
Credit: 26,674
RAC: 0
China
Message 10062 - Posted: 19 Jul 2004, 22:53:38 UTC
Last modified: 19 Jul 2004, 22:58:05 UTC

I don't know if this will be of any help or consolation,
but I am running BOINC on RH9, Intel 1.2 GHz proc, 128MB.
I'm not a speed demon..my WU's are avg. a little over 7hrs...
am just using a priority 19, perhaps you could try running at
priority zero or below...on the flip side, when I run BOINC with
Windows XP my WU's avg. almost 10 hrs...I don't know how
fast you were crunching Wu's before,try changing the priority...
just a suggest. For me 7 hrs is cool...Reporting live
from Chongqing China...Xi3...July 20 06:50 local time.
BTW....using my gf's comp. some Chinese brand I can't even
read the name of...
<a> [/url]

Profile Ja_de_Sam
Send message
Joined: 25 Oct 01
Posts: 1
Credit: 232,239
RAC: 0
Czech Republic
Message 15100 - Posted: 10 Aug 2004, 4:47:32 UTC

same problem ...
2x opteron 242 (1,6GHz), 2.6.7 (32bit only) Recent average credit 115
1x barton 2,0GHz Wxp 102

something is wrong in linux client ...

Profile Crunch3r
Volunteer tester
Avatar
Send message
Joined: 15 Apr 99
Posts: 1540
Credit: 3,314,460
RAC: 338
Germany
Message 15138 - Posted: 10 Aug 2004, 10:30:51 UTC - in response to Message 15100.

> same problem ...
> 2x opteron 242 (1,6GHz), 2.6.7 (32bit only) Recent average credit 115
> 1x barton 2,0GHz Wxp 102
>
> something is wrong in linux client ...
>
>
The Problem is that the clients are not optimized.
Try to compile your Athlon XP (both boinc_client & seti_core client) with the gcc flags :
CFLAGS="-O3 -march=athlon-xp -fomit-frame-pointer -mmmx -m3dnow -msse -m3dnowext -fexpensive-optimizations"
---------------------------------------------------------------------------
the opteron should look like this:
CFLAGS="-O3 -march=x86_64 -fomit-frame-pointer -mmmx -m3dnow -m3dnowext -msse -msse2 -fexpensive-optimizations"
----------------------------------------------------------------------------

Questions and Answers : Unix/Linux : Why so slow? What to do?

Copyright © 2014 University of California